Animation doesn't work under UE 4.7.0

Hi there, I was doing Epic’s official ShooterGame template on UE 4.6.1 and updated the project to 4.7 compatible one by myself (not using the official 4.7 one because I added some custom feature on the 4.6 project).

The issue is that when under PIE mode I need compile the animation blueprint every time before I run the game, otherwise the animations won’t work. And when under standalone mode the animations don’t work even if I pre-compile them. It looks like a stand-still character moving around in the level without any walking/jumping/running anims.

What I changed in code (only to kill bugs, no functional update):

  1. update all ControllerId to GetControllerId() or SetControllerId(index)

  2. EOnJoinSessionCompleteResult type name “RoomIsFull” to “SessionIsFull”, “RoomDoesNotExist” to “SessionDoesNotExist”

  3. BlackboardComp->InitializeBlackboard(*Bot->BotBehavior->BlackboardAsset), add an asterisk to change the pointer to reference type

  4. comment out bReplicateInstigator in 2 places

  5. comment out DisplayAccountUpgradeDialog in 1 place

I tried official ShooterGame 4.7 template and it works well, so I think it’s my missing something when updating the project from 4.6 to 4.7. Any suggestion may help, thanks in advance!