Download

Animation did not import from 3ds max

Hello all,

I’ve got a set of arms that I would like to import into UE4 that are rigged with a skin modifier. I export the arms as an .fbx in max and it comes with a single animation that I made and had just to test it to see if it could transfer over. I then import into UE4 as a skeletal mesh. The problem is that the animation didn’t come with. Please see these pictures below and notice how there is a mesh and bones but no animation:

NoAnim1.jpg

What I did was keyframe a quick animation in Max but it didn’t transfer over. The animation sections says ‘None’. Please if anyone could help I would really appreciate it. Thanks!

Hi,

I just tested a simple asset I created in 3Ds Max and everything checked out on my end.

For my export from Max I made sure that the animations were checked for export on the FBX Export options.

When I imported into UE4 I used the default settings. I opened the Skeletal Mesh and selected the Animation Tab (the one that says “None” in your image). While mine did say “none” initially I went to the animation tab and could see my animation present in the listed Asset browser in the bottom right.

Can you verify that this is the case for you as well?

Thank you!

Tim

Tim, thank you for the reply. Yes I saw the Asset Browser in the bottom right when clicking on the Animation tab. Unfortunately it does not show anything to choose from. I did make sure that I checked to export the Animations on the FBX exporter dialog.

Maybe I did something wrong in 3ds Max? Here is a screenshot of what I have going on in there:

4d895fbe3f20315ebe33d7ff5f50581e591084bc.png

All im doing is moving the wrist and auto-keying for a simple test animation. There should be an animation that is 100 frames long that comes with. Is there something more to it than just that? There was also a warning about non-orthogonal axes upon exporting

Thank you.

Sorry for the double post, but just tried to import a simple asset (a cylinder) that has one animation that moves it up and down over 100 frames. I import the FBX as a skeletal mesh but the animation is no where to be found so that proves that it has nothing to do with that previous fbx warning that I had. I’m using 3ds Max 2015 and UE 4.4.3 . Someone pleaseee help meee! There has to be a misunderstanding somewhere.

EDIT: I checked the box on FBX Import that says ‘Import Animation’ Name ___. That worked! I guess I thought it would’ve imported automatically.