Animation Blueprint is Glitched?

I have no idea what’s causing the problem, so let me just explain everything I did:

In the third person template’s default animation blueprint, I went to the “JumpStart to JumpLoop” location rule, which originally looked like this:


As I was playing around with the editor, (I have watched tutorials on the subject,) I deleted that first node in the image above, the one called “ThirdPersonJump_Start Asset Time Remaining (ratio)”. But later, I wanted to put that node back, but I couldn’t find it anywhere! How come?

Instead I found another node, which appears to be the same thing but with a different look:

(Is this the same node or not?)

But now the animation looks bad! And very inconsistent too. Sometimes the jump start anim plays repeatedly over and over, even while on ground, sometimes the mesh will rapidly rotate side to side, sometimes it plays all choppy, I just don’t get it.

I tried making a new third person template project to see if I could recreate the problem, but to no success. The thing about the disappearing node still happened, but the animation still plays smoothly.

So that means the problem is either a glitch, or I accidentally changed some other setting in the editor without realizing it. Any idea what that could’ve been? I can’t see any difference between the two blueprints.

The glitchy animation was caused by the jump start animation being set to loop. :confused: I had deleted that node and replaced it, which apparently sets it to loop by default. The anim inconsistency is do to the jump having controllable height.

I’m new to anim blueprints as you can tell. So sorry about that… ^^