Animation blueprint construction script only updating most recent actor instance

I have a blueprint class consisting of a skeletal mesh component with an attached animation blueprint. The skeletal mesh has 2 morph targets that are meant to be modified in the editor when the user places the actor in the level. The blueprint has a public variable that sets the value of the morph targets in the construction script based on different criteria. The animation blueprint draws the morph target variables from the blueprint class and sets the morphs accordingly using a “get actors from class” and a “for each” loop in the event graph.

When I initially set the blueprint up a few days ago, everything worked fine with the occasional hiccup forcing you to change a value in the editor to re-update the morphs. However, I didn’t test it with multiple instances of the blueprint class until this morning. It seems that when you place one it works fine; when you place a second one, it works fine; if you go back to the first one, the animation blueprint no longer updates the morph target values correctly in the first one. I’ve tried it with multiple instances messing with different values and it appears that only the most recently placed instance is able to be manipulated correctly. The previous ones just break if you need to go back and change any values.

When I get back to my office I can upload a screenshot showing the current setup if needed but does anyone have a ballpark answer as to what might be going wrong. I could be wrong but I feel like it has something to do with the anim bp losing some kind of focus on each instance as a new one is added. Maybe an issue with the for each loop.

I am just sort of spit-balling at the moment but if anyone has any ideas it would be greatly appreciated.


Here is the screenshot

I guess no one else has ever experienced this? Anyone have any ideas regardless?