Download

animation blending issue

Hi!

I’m trying to use animations from different sources in my character. I have imported these anims and selected my character skeleton for them. Individually the animations look ok but when I try to blend between them the result is incorrect.

Here is a video showing the problem:
https://youtube.com/watch?v=cd3kWWxpVrY

Do you know if it’s possible to fix it in UE?? Any tip??

Thanks

I tried to play around with this tutorial: https://www.youtube.com/watch?v=SgsYsViIRYE and finally have the same issue. Unfortunataly without solution. I’ve compared z of root and pelvis to find a reason for the difference from both animations but they are pretty much in the same height (maybe 1 mm up or down) but if I blend from idle to idle_ironsight my character is diving into the ground while he is blending (similar like in your video) until he finished and using the final animation. If I change the “duration” value in the “transition rule” of the anim blueprint from 0.2 to 0.0 he does not dive into the ground anymore. Start and Final animation looks perfect in that case but he does not do a soft blend anymore as well. So changing to 0.0 is ugly and no solution. I’ve no idea why he is messing up Z pos (just) while he is blending.

I believe your issue may be tied to what Zak Parrish covers in this video at about [3:40]: https://www.youtube.com/watch?v=S8ardXXy5pE&list=PLZlv_N0_O1gaCL2XjKluO7N2Pmmw9pvhE&index=75

Let me know if setting “Animation Scaled” to the pelvis bones of your animation resolves your issue.

-Thanks.

Hi Kanc, would you be willing to provide your files via PM for us to take a look at?

Hie Steve,

This looks pretty much the very same issue as the issue in this thread: https://forums.unrealengine.com/showthread.php?78885-Animation-Blend-Per-Bool-Issue-Weird-Pop-or-Jump-or-something

4.8.3:
*) Create New Project -> Third person
*) Switch back to library and do “Animation Starter Pack” -> Add to project (looks like Kanc is using some ninja anim at this point instead)
*) Setup retargetting for UE4_Mannequin_Skeleton found in Content\ThirdPersonBP\Charater\Mesh to Humanoid Rig and switch pelvis bone to Animation scaled
*) Setup retargetting for UE4_Mannequin_Skeleton found in Content\AnimStarterPack\UE4_Mannequin\Mesh to Humanoid Rig
*) Retarget any of the animations found in Content\AnimStarterPack for example Idle_Pistol or Idle_Rifle_Ironsight
*) Create a 1D blendspace for your skeleton found in Content\ThirdPersonBP\Charater\Mesh from ThirdPersonIdle to Idle_Pistol_Copy and make Bones visible.

[QUOTE=Neutronux;348913]
Hie Steve,

This looks pretty much the very same issue as the issue in this thread: https://forums.unrealengine.com/showthread.php?78885-Animation-Blend-Per-Bool-Issue-Weird-Pop-or-Jump-or-something

Hi Neutronux,

I have used your repro steps to report the bug and responded to that thread. The status of this bug will be posted to that thread as it is linked in the bug report. Thank you for the feedback!