Animation asset dropdown keeps disappearing

I have a simple animated windmill that I am importing from Modo via FBX. Everything works fine, but every once in a while I will notice that the animation is no longer playing, and when I go into the Actor panel, select the component and look in the Animation pane, the “Animation Mode” is still set to “use animation asset” (which I had previously selected) but the dropdown menu is GONE entirely. What’s happening here? I keep having to re-import my assets and it’s a huge waste of time.


So I may have discovered the issue. It seems that UE4 allows you to import assets with improper filenames (illegal characters such as blank spaces and parentheses). I tried going thru and fixing these in UE4 immediately after importing my files, and so far nothing is getting lost.

Perhaps Unreal should prompt you to correct these upon import - could save someone a lot of hassle.

Hey christian-idean,

Could you tell me the name of your fbx files? We are having trouble reproducing this on our end. When importing fbx files with invalid characters (parentheses, spaces, etc), they are turned into underscores.

Even better might be to get a copy of your fbx file so we can figure out why the editor is treating them differently. You can attach here or PM me a download link on the forums.

Thanks for reporting this! Maybe you’ve found a loophole in the fbx import.

PS - The behavior I believe it is exposing is related to UE-35537, but the underlying cause you’re reporting sounds like a separate issue.

One of our engineers wanted to ask if you’re on 4.13.0 or 4.13.1.

Hi . I’m using 4.13.1. I apologize as I’m swamped at work and probably can’t devote any time to experimenting and trying to pinpoint this issue right now. I should clarify tho, it wasn’t the filenames themselves that had the illegal characters but the object names (I believe) - the actual items within the FBX file (I selected a number of objects in Modo and exported as a single FBX) which would have contained mesh items with baked animations as well as “locators” that I was using in my heirarchy (I have no idea what happens to those when you export/import into Unreal). Hope that’s in some way helpful. If I get a break in the next week or so I’ll try to spend a bit more time with this. Thanks for your quick responses.

I marked this as an accepted answer for tracking purposes. I’ve tried reproducing this with Modo(Maya won’t even let me use parenthesis), but was unable to repro. If you have time to investigate in the coming weeks, just respond here with your findings.