Animation and Rigging toolkit error

Does anybody know why I get “File contains unknown nodes or data. To preserve this information, the current file type cannot be changed.” When hitting “Build” in the Publish Character section.

I have looked everywhere for a solution, only thing I could find was telling me to preserve the unknown nodes by saving the file type as maya ascii, I did this and I still have the issue.

Any help is appreciated ! :slight_smile:

Hey TheMunky -

What version of Maya are your using?

Thank You

Eric Ketchum

Was worried I wasn’t going to get a reply, really stuck on this, I am using Maya 2015

Have you gotten the most up to date version of the ART from here:

Dropbox - Maya_AnimationRiggingTools - Simplify your life

You also may want to look through the Forums by ART tool creator Jeremy Ernst:

Animation and Rigging Tools: FAQ, Known Issues and Feature Roadmap - Character & Animation - Unreal Engine Forums

Let me know -

Eric Ketchum

heya!

I have come across this error as well, but I’ve never been able to figure out the solid repro steps. Basically, it marks one of the nodes (skeletonSettings_cache) as unknown and then refuses to save. The one thing I have noticed is this usually only happens to me after I’ve imported something, either an obj or fbx. Depending on where the mesh is coming from, it may be bringing along some junk with it.

The workaround for your file currently would be to save out your skin weights (using the export skin weights button in the UI), then go back a step to placement, and save out a template for that, and then go back to creation and save out a template for that.

Then you should be able to do a new scene, bring in your mesh again, and go to file->optimize scene size options, making sure remove unknown nodes is checked, then run it. Now launch the tool, load your skeleton template, then load your joint mover template, then when you get to deformation, import your skin weights.

I do have a fix for this I’m working on, but it’s not done yet, so unfortunately that workaround is your best bet for continuing to work with that file.

Sorry!

Still receiving the bug, any advance in reg. the fix, yet? Cheers