Anim Retarget problems

Hello,

now that the 4.6 Preview is available I decided to give Anim Retargetting another try,

the 4.6 Preview successfully fixed -[this][1]- crash, even if the Target Window still displays an empty grid. but I can live with that.

now after trying for a bit I can’t for the life of me set it up in a way to work with a standard 3dsmax biped. the number of bones and placement is quite similar, but it turns out the differences in the skeleton hierarchy are probably much more of a problem than I expected.

this is how it looks like:

I will list my problems here.

(1). the most obvious problem is the arms.

the probable cause:

  • In the HeroTPP skeleton the Twist Bones are children of the bones they are meant to twist. for example upperarm_twist_01_r is a child of upperarm_r.

  • However in the Biped Skeleton R-UpperArmTwist is a child of R-Clavicle, just as R-UpperArm is also a child of R-Clavicle. as such, they are “brothers” in the hierarchy.

is such a difference just not supported? I tried changing the Retargetting pose for the arms and nothing I did made a difference.

an additional burden: as you might or might now know, Biped is very rigid in some aspects. Most notably, it doesn’t allow modifications to the bone hierarchy, which means I cannot modify my skeleton’s hierarchy to match the one in the HeroTPP skeleton.

(2). the upper back and neck.

while not as evident from the previous view, here’s what it looks like:

21675-animretarget2.png

it would seem that adjusting the Retargetting Pose would fix it, but it really made no difference.

in fact no matter what I do with the Retargetting Pose seems to make any difference whatsoever. I even tried making my Retargetting Pose like this:

21676-animretarget3.png

guess what the result was… yes, the exact same result as in the very first picture. not the slightest difference in the torso, nor any differences between the Left and Right arm and leg.

(3). because of what I describe above about the Retargetting Pose not affecting anything, I cannot do anything to even try to fix the feet, toes, or the torso/pelvis.

(4). I also get -[this][5]- problem.

once again this makes me sad. this feature was introduced in 4.4 and now we’re (almost) in 4.6 and I still cannot use it in a way that yields any positive results.

I cannot leave Biped behind because I have over 115 animations made for my Biped rig and I don’t want to be forced to choose between my own animations and the possibility to buy and use new ones from the Marketplace.

so please could it be made possible to use one of the industry standard tools for animation (Biped) in conjunction with the one Skeleton setup that is and will be used for every single asset in the UE4 marketplace?

thanks

Hello Chosker,

It does seem the hierarchy of the Biped in 3ds Max is different than the one set up in the engine. Unfortunately there is no way to adjust the hierarchy of the Biped in Max without messing up your animations. My best suggestion would be to follow these steps to see if you haven’t mis-targeted your skeleton at all. This is a bit tedious, but could end up saving you in the long run. Be sure to double check the bones you are trying to use match up with the correct location you are attempting to assign it.

Follow this documentation for the steps to follow and for advice on how to make adjustments.

Different Skeleton
https://docs.unrealengine.com/latest/INT/Engine/Animation/RetargetingDifferentSkeletons/index.html

Same Skeleton

Hope this helps,

Andrew Hurley

thanks for the followup

Since the first post I had already followed all the steps of the documentation, and made sure every bone in the skeleton was matching their equivalents by the correct name (despite the difference in the hierarchy) - clavicle with clavicle, upper arm with upper arm, upper arm twist with upper arm twist, and so on for every bone in the Base and the Advanced configurations (so yes, even every finger).
just in case I just double-checked again and all the bones match.

what I didn’t try before was the part in the docs about the adjustments, setting the Translation Retargetting to Skeleton for those bones that were not matching. with this I was able to fix the problems caused by the differences in the hierarchy (yay!) which fixed most of the problems. the octopus arms are gone and the problems in the neck, waist and toes seem fixed.

the problem is now only about the rotation of the arms. when I retarget the walk animation it looks like this:

this problem is covered in -[this][2]- part of the documentation, and it would seem to solve my problem because my model is also rigged in an A pose. however like I described in my first post, adjusting the Retargetting Pose doesn’t change anything.

this is what my pose looks like:

as you see, it matches the T pose.

like I said before though, I can modify the pose to any crazy pose and it produces no visible changes. is this a bug?

I know this sounds silly, but after viewing the pose and readjusting it so it matches the correct pose of the skeleton, are you saving it back out? ‘Save Pose.’

yes of course :slight_smile:

I adjusted the pose, clicked Save Pose, saved the skeleton asset and then re-targetted the animation all over again (which produces a new animation with the new retargetted information).

I can close the editor and re-open it again and View Pose still shows the new pose as I left it in T pose

this process was good and working to reflect changes before (like when I fixed the arms), but again, it doesn’t reflect any changes I do to the pose whatsoever. which is why I ask - is this a bug?

I managed to see what you are talking about by doing some tests on my own end. The T-Pose that you are seeing by default is essentially a placeholder meant to represent the most common and default base pose for most skeletal rigs.

After you re-opened the Base Pose Editor and were seeing the T-Pose, try pressing View Pose again to see where you originally edited the base pose. This should be showing you the right position. Again, the T-Pose provides you with a visual reference as to the default position of your skeletal rig, so this is why when you don’t press view pose, you are seeing the T-Pose.

no no you got it wrong.
if I open my skeleton I see my A-Pose. if I press View Pose I see the [modified] T-Pose. if I press Hide Pose I see my original A-Pose again

Well I tested out the base pose re-targeting without creating new animations and re-targeting the skeleton. Since I did not re-target the skeleton as you, my default pose is the T-Pose, where yours is the A-Pose because you did re-target the skeleton.

I will investigate to make sure this is the correct outcome, but this could be what is causing your issue to occur with your arms being offset. Unless you managed to fix that while re-targeting with your new base pose?

no, I didn’t change the base pose of my model/skeleton. my default pose is the A-Pose and what I tried to change was the retarget base pose (only in the retarget manager) to match the T-Pose (with the View Pose thingy) - but my model still has an A-Pose.

and the issue with the pose is still there (arms inside the body), I couldn’t fix it. because, again, no matter what I do when I change the pose in the retargetting manager, no matter how crazy pose I put it on, I never get any different outcome.

This does sound like a bug, but the ones in charge of the Animation re-targeting are currently out for the Thanksgiving Break since it is a National Holiday. I will make this issue aware to the developers, but I cannot guarantee it will be addressed by this week because they are out of the office till next week.

I will continue to research this issue myself to see if we can’t resolve it as well. I appreciate your patience with this issue and the information you have provided so we can get this straight.

Andrew Hurley

yes I was also suspecting it would be a bug, because literally nothing happens.

I’m not using GitHub (only 4.6 Preview) so an immediate fix wouldn’t even benefit me. take your time, I just hope it can be fixed before the full 4.6 release :slight_smile:

thanks again

hello again,

I just tested this on the newly released full 4.6 and the problem still persists

hope to see it resolved soon

regards,

Chosker

Hey Chosker,

Thanks for the update. The developers are aware of the issue and are working to have it tested and resolved. We appreciate your report as it helps us improve upon our functionality and features of the engine.

I will keep this question open until an answer is found. I will keep you updated on the progress as well.

Thanks again,

Andrew Hurley

What do you see in retarget window? If you see T-pose there, animation retargeting system is using the pose.

By the way, once you change retarget base pose, you should save mesh instead of skeleton.

If you see all this correctly, it might be just different issue why the arms are not working. Do you have any extra bone in the arm chain?

Thanks,

–Lina,

ok I figured it out. the key was the fact that this is saved into the mesh and not into the skeleton.

the thing is I have a modular Pawn (head separate from body) and then I have a mesh that is the full head+body for easier testing. but the skeleton’s default mesh was the head and I was still testing with the full one.

now after I set the default mesh of the skeleton to be the full mesh, the changes I do to the retargetting pose now are applied to the retargetting as well

I wonder why this pose information is stored into the mesh though. it’s the skeleton that is used for retargetting isn’t it? it’s just confusing :confused:

anyway thanks for the help, everything looks in place now and I can fine-tune my pose. and once 4.6.1 is out the animations should loop seamlesly

so thanks again :slight_smile:

It is a bit tricky but it is the same reason that all meshes has all different reference pose. Although retarget works based on skeleton w.r.t. hierarchy, I couldn’t use skeleton ref pose(which technically isn’t used anywhere else visually). To make it work for retargeting the pose has to be very accurate otherwise it doesn’t retarget correctly, so it uses mesh ref pose, thus the retarget base pose is saved to mesh.

Once we have retarget system work in in run-time, we might not even need skeleton anymore, but we’ll see. That’s a long term plan. :slight_smile:

–Lina,

So… Currently does anyone have a workaround this problem? I was able to get my character to not have spiral hands, but stuck on his arms clipping to his stomach.

problem still persist - 4.10

Me toooooooooooooooooooooooooooooooooooooo!!!
Biped of 3dmax…
I‘m so paining.

I had the exact same problem with my own character (curly fry arms included). This tutorial did the trick and now I’m using this animation BP with my own custom character without issue.

It isn’t in English but that doesn’t matter if your following along with your project open. There is also a section on creating a Blueprint Interface which you don’t need to do with the version 2 of the blueprint. There is also another part where he adds some custom climbing ladder animations, which is not relevant unless you have more marketplace animations you want to add to your character.

Basically what I got out of the tutorial that helped me immensely was creating virtual bones to take the place of the IK setup in the default skeleton, and setting your character to a t-pose before retargeting the animations.

I do realize this question has been active for a couple of years, I’m simply leaving this info here for anybody fumbling around with the same problem.