Download

Anim Notify's not showing up in AnimBP Eventgraph

Help! My anim notify’s cannon be added to my Anim Blueprint eventgraph.
I added them to my Anim Montages but when I try to add them as nodes in the eventgraph nothing shows up. I tried un-ticking context sensitivity. I double checked that they were still there in the montages.
I also read about an old but about this with reccomendation to restart editor, so I did that too but nothing still shows up.

What could be the reason for this would anyone know?
Is there another way to get the nodes in the graph?

EDIT: Aha! After several restarts and double checks without a better result I just tried to add a custom notify to a regular imported animation (not a montage).
and BAM there it showed up in my node creation list. But also it seems to have triggered my custom notifys for my montages to also appear. Seems like a bug to me.
(there’s also a few refresh/update bugs with the Anim Slots that keep doubling up)

Cheers
Fred

The struggle is real… This problem still occurs in 4.16 version. Please fix this one.

This is still an issue!

This also happened to me.
In my case, it was a c ++ project, after compiling the project in the editor, the problem was solved.

Seems to be related to the name of the animnotify. I used skeleton notifies with underscores in the name and they didn’t show up in the anim blueprint. Remove the underscores and, after saving all, they did.

There are several panels from which a notify can be added.
as well as different types of notifies.

Generally if you don’t see the notify, it means you used the wrong panel or the wrong type of notify.

All a notify is, in the end, is a custom event.
Check out the official docs, the Custom Notify States section should cover some examples of how to set up your own states with full BP access.