Anim notify Play sound bugged 4.6.1

I am using source built v4.6.1.

I can put anim notifies on the animation track to play sound but I can neither assign a sound cue nor set the bone for location.

Any selection I make is simply ignored and not selected in the anim notify, the anim notify fields simply stay none no matter what I do.

see below for a visual recording of the problem

It looks like you are assigning wave files directly. Have you tried assigning a .cue instead?

yes the same thing happens

Heyo Shep,

I am setting up a 4.6.1 source build right now to try this out. It does not reproduce in the Binary build from the launcher (at least on the assets from the 3rd person template).

Is this problem occurring with all animations in this project? If so, can you create a fresh project, import your mesh, skeleton, and animation(s), then check if it happens there too?

Depending on those results, I may ask if you could upload your .uassets and maybe even your project.

Keep fighting the Reapers,

Matt W.

Hehe, yes I’ll save the galaxy

Actually this is a fresh project I have made all animations fresh on a mesh that I got from mixamo and the sound Waves and cues are also external to the launcher or engine.

Once I was able to select a cue by using “+create new cue” but it did not work on another notify :frowning:

So It was only and only once I got it to work by chance and it didn’t worked ever again. As for uploading I got no issues except I’m limited by bandwidth but I’ll try ASAP

Oh man 4.7 stable release is out! I’ll try migrating stuff and see if it works

Hey Shep,

Just want to follow up and see if 4.7 fixed your problem. If not, it’d be great to get a copy of your project. :slight_smile:

-Matt

As I said I’m running low on bandwidth , please bear with me for 1-2 days and don’t kill this question.

Hey Shep,

I was just checking up. It’s nowhere near stale enough for that kind of action. :slight_smile:

Yeh! This seems to be a bug in 4.6.1. I just made a fresh project in precompiled 4.7.1 from launcher and everything works fine. Although converting the 4.6.1 project to 4.7.1 gave the same bug, but a new project works absolutely fine

That’s great! Could you try converting your project, then re-importing these specific assets? I wouldn’t want you to have to recreate your whole project from scratch in 4.7.1.

-Matt

Ah no its fine, as you can see my project was in its beginner stage so I can indeed restart fresh. Also converting the project failed

Ok, glad it’s working for you now. We are working through some conversion issues right now and hope to have any of those resolved before the next release.

Thanks for reporting this!

-Matt