Android Works from Nvidia

This is a two-reason post. I make it mainly for the hope of Epic making better support for the native Android SDKs. I installed them all individually and Unreal Engine failed to compile even a simple project.

The second reason is more a rant and will probably get replies like “get over it”. But that juggernaut of a package that Android Works from Nvidia is, tipped me over again when I today hit the infamous error that the installation path cannot have spaces.

So where in this century can not an installation path have spaces in it? Non-space is pre-Windows 95. I know it cannot be incompetence, but is the reason really because Nvidia mainly do drivers and are to low level to operate with spaces? Are their coding so fragile that spaces in the installation path will brake it? Or are they just used to doing it like this? Stuck in a 20 year old policy and can’t get out?

Now back to Epic and please make the native Android SDKs working. I already have them all installed due to Android Studio and there really shouldn’t be a reason to have two separate and nearly identical packages installed. I already did a post a while back about the specific compile problem, but the answer seemed to be “install Android Works”.

Hi Ruudscorner,

You can install the Android NDK and SDK yourself if you like, but it is easier to use the installer since it is configured to download the required parts. If you do install them yourself, you need to make sure you have NDK r10e with platform API 19 and the same for the SDK. Either set the environment variables yourself or set the paths in the editor’s Android SDK project settings. At a minimum, you need to set NDKROOT to point to the NDK. After setting the Android SDK path it should be able to find ADB needed to detect devices.

Thanks. I did ask this before on AnswerHub, and this is why I thought the native SDK didn’t work -

After your reply I reinstalled all the packages again and made sure a few of the environment variables was set. It now works. Thanks again :slight_smile: