[android] Unable to start game if I package with Distribution ticked

i’m doing a simple project for android and nearly finished (i hope) to learn the engine - also about 1 month now - and I’m stuck on the last step and wondering if anyone has experienced a similar problem and if so how to solved it!

Exporting my project runs fine in both development and shipping configurations but as soon as I tick the ‘Distribution’ box so I can upload to the play store my app no longer runs - short black screen then back to ‘desktop’
(To be clear I am exporting with Shipping and Distribution mode ticked)

I have created my keystore and included its details in SigningConfig.xml in myproject/Build/Android and according to the export output log there are no errors - verfying the apk also reports no errors. When I install via ‘Install_myProject_Shipping.bat’ is when the app no longer runs. I also confirmed the same problem uploading it to the play store and installing from there :confused: also does not appear to be related to the keystore since with the same one I could sign and run tappyChicken no problems.

Did anyone run into this problem as well? Wondering if there is something I’m missing in the AndroidManifest.xml - I already found out I need to manually update the version in there for uploading a new version to the app store.

The only error I see in the Android Debug Monitor is:

tag: libc
text: fatal signal 11 (sigsegv) at 0x0000002c (code=1), thread 18719

which this error message seems to mean anything :frowning:

FYI: UE4 version 4.3 & 4.3.1 - project originally started in 4.2.0

After a week of frustration I found a solution - I created a new project copied the Content from my original project into it - went through all the project settings again and now it is working.

Not sure why it was broken - either all the converting of the project over each UE4 version from 4.2.1 or me renaming the project at some stage by doing this: https://answers.unrealengine.com/questions/45690/how-i-can-rename-my-pojects.html

Reason I tried this ‘fix’ was I went back to one of my older backed up versions of the project on 4.2.1 and it was working so knew it must have been a project setting over time since that broke the distribution export

I had the problem. I deleted folder “Build” in my project folder. Then in project settings>android configure it for Android platform once more. Don’t forget save SigningConfig before delete build folder.