Android set up trouble


Ive set up my project to be a mobile project and have configured it for android. Ive down loaded Android studio and the sdk, ndks within Android studio. Ive also downloaded the most recent JDK i believe version 22. Ive set the paths in the project settings to the locations of each dev kit (sdk, ndk, and jdk). Ive unlocked developer mode on my phone and have also connected it to my conputer using a usb.

Ive also followed a few different youtube tutorials on setting up an android project wothout any luck.

So my issue is that each time i try to package or cook the project for android it tells me i dont have the binaries. It asks if i would like to install them from the epic launcher. I select yes and it asks me for a destination. I pick one and nothing ends up happening. Ive also tried to refresh the available device list to see if that helps. At one point i was able to get the android list to show my phone and select to update decive. It showed that the sdk was found and set up (got the green check mark). After selecting to restart the software it still didnt show android as vaild and had the warning symbol next to the android selection.

I thought that the binaries where the sdk, ndk, and jdk i downloaded and set paths to? Is that not the case?

Any help would be grateful. Thanks in advance.

Did you set the paths of the SDK/NDK in the environment variables

1 Like

No didnt know that was a thing. I look up where to try that next.

This is the current setup guide for UE5.3, but it should work with 5.4 as well. Also this should work with newer versions of Android Studio.

1 Like

Thanks @OrbitalZones for the set up guide. Ill looke this over and give it a go.

@OrbitalZones I followed the doc you sent and i am still having issues. I checked the environment variables and deleted them before running the android setup batch file like the steps said to. Restarted the computer and have my phone connected to my computer. My phone is being found. I select to update the device but after restarting UE im still in the same boat.

I notice that when i attempt to update the phone i see

UATHelper: Installing Sdk (Android): Platform indicator Android_ASTC is an invalid platform, skipping
UATHelper: Installing Sdk (Android): Unable to find any devices for platform(s):
UATHelper: Installing Sdk (Android): Platform(s) and/or device(s) needed for VerifySdk command. Check parameters or selections.

But just after i see

UATHelper: Installing Sdk (Android): Cleaning Temp Paths…
UATHelper: Installing Sdk (Android): BUILD SUCCESSFUL

Any further help would be appreciated

I just checked again my settings and even updated to Android Studio Koala 2024.1.1

Apparently UE5.4 support another way to setup the Android SDK via Turnkey, but to be honest I never tried this option. Maybe my current SDK settings were carried over from UE5.3.

Not sure if that will help but just in case, here are my platform settings for Android SDK, environment variables are unchanged. Make sure you have the Android SDK Command-line tools installed in Android Studio settings (SDK Tools).

Ill try the steps in the link and match with your settings too after i get off work today. If i understand right the evirinment variables only matter if you oeave those fields blank. As it will default to the evironment variable values.