Download

Android SDK and API 23

The latest Android SDK API 23 made some changes impacting packaging or launch on for Unreal projects. The AndroidWorks installer included in Engine/Extras/Android should only install up to API 22 by default but if you are using 1R2 from the NVIDIA website it may be pulling down 23 as well.

API 23 removed org.org.apache.http from the standard package and moved it to optional. Unfortunately, it also removed some depreciated API calls which Google’s APK expansion downloader depends on (we use it for OBB download). The best thing to do for now is use no later than SDK API 22.

The Android SDK section of Project Settings allows setting the SDK API Level and NDK API Level. By default, SDK API Level is “latest” and NDK API Level is “android-19”. The NDK API Level should be set to “android-19” if you wish to target devices before Lollipop (5.0). If you set this to “android-21” or higher, your APK will only work on 5.0 devices.

SDK API Level set to “latest” will use the highest number found installed. If you have API-23 installed, you should change the SDK API Level from “latest” to “matchndk” or “android-21” (check your SDK’s platforms directory for which versions are available). It is OK for SDK to be set higher than NDK.

Thanks Chris, that’s a shout.

Speaking of which, is the AndroidWorks 1R2 over the 1R1 something you support/recommend?

Thanks for all the great work on the Android front, especially in 4.9.

Minxies

AndroidWorks 1R2 will work, but you need to make sure you set the SDK API Level appropriately and make sure API 19 is installed. The installer we include in 4.9 is based on 1R1 and has the proper defaults.

I do have a Nexus 9 with android 6. Will 4.10 use the features in 6. In the config do I put android-23? I do have api 23 installed.

Chris, no answer. I put the question in the AnswerHub and no help. Too hard of a question???

Hi theProfessor,

Sorry, I was out and didn’t see this. 4.10 does not use any Android 6.0 features at this point. Do not try to use android-23, Google’s APK expansion library doesn’t support it yet.

Hello, im having issues rendering transparent materials on Android 6.0 (HTC One M9), This issue came up after I upgraded to 6.0. I cant seem to find other people with this problem now. so checking here!

Morgansandb,

Could you please submit an Answerhub if you haven’t resolved this issue as of yet? I have tested this out on an Android 6.0 Nvidia Shield with transparent objects within the level. I did not run into any trouble.

Thanks!

I have already installed API 23 (SDK platform, tools, docs, sources). In fact I tried to reinstall all of it, but didn’t help

You should use only up to API 22 at this time as I mentioned in the first post in this thread; 23 will not work because it depreciates some APIs we are still using in the downloader.

Yeah, I know still we use up to API 22. The latest update to Android (Version 5.1 of Lollipop rolls out)… Google has just officially announced the 5.1 SDK, which now represents API Level 22, to enable development and testing of the latest features.

So this might be why my Android device isn’t showing in the launch section? I know I’ve got the API 23 installed. So I should just install API 21 and set ‘android-21’?

thanks for your that i have the same issue :smiley: http://www.scatzx.com/img/1476275272.jpg

I’ve done as you said but now I am getting this error: Requires at least SDK API level 23, currently set to ‘android-22’
Program.Main: ERROR: AutomationTool terminated with exception: ERROR: Can’t make an APK without API ‘android-23’ minimum installed (see “android.bat list targets”)

4.16 requires android-23. Run android.bat and select Android-23 and install it.

i have unreal engine 4.16.3 installed via github sources. i already installed latest android works given in extras/android. matchndk,latest. target is set to android-19.but am not able to install apk in android version lower than lollipop.what should i do to make apks for kitkat and lollipop.

In fact I tried to reinstall all of it, but didn’t help

The original post is from 2015, perhaps a new update?

Android 23 and up is not a problem any more. Android 23 is now the minimum required and is installed with CodeWorks for Android 1r6u1 installer in Engine/Extras. It is best to set NDK API Level to “android-19” and SDK API Level to “latest” now.

Help please! after open “CodeWorksforAndroid-1R6u1-windows.exe” press next as usaul. it shows “Downloading update lock” and then it shows “error”. I even can’t select the version i want to download! Any help please. Great thanks