Download

android packaging in jenkins

that cmd was taken from unreal editor upon a successful packaging.
same cmd works fine when i copy paste in windows command prompt .

but this command fails in jenkins.
at the begining it was failing for not being able to identify android sdk, ndk and jdk. bcz NVPACK installer add those path in uer level of environment. but jenkin use system level of varaibles. so i had to sopy paste them in system level.

that solved the tools locating errors.

in 2nd stage i faced another issues which was causing for a bug in android gradle plugin. sadly ue4 still uses that old buggy gradle plaugin. atleast in 4.21.1.
to solve that i fixed this

which was fixed by adding this

and

that solved that new error caused by the gradle bug.

now i am getting this errors>

note>
none of these error happens in unreal editor or using cmd prompot.

only happining inside jenkins.

did anybody have luck to have succeful android packaging using jenkins ??

did anybody get any success with android packing in jenkins?