Android Packaging For Distribution Fails


First Time doing this

I’ve been trying to upload my apk to google play and have been struggling to get the packaging done.

The game packages fine without the “For distribution” box checked.
I have generated the keystore file and it is in my Build\Android folder.
Also I have the distribution signing info correctly placed.

My SDK location are correctly linked. Though I would point that both my engine, project and NVPACK folder are not in the default location but in my own custom location. The NVPACK is fully updated aswell.

I want to package the game with ETC1 but I have been doing it with Android (All) just to see if that was the issue.
My game is already linked with Google play services.

Kindly help someone.
Much appreciated.

Hmph. Never mind I solved the issue.

But I’ll still give out the solution to help someone.

Firstly, My keystore file was missing alias name.
So I created a new keystore file from cmd prompt. keytool -genkey -v -keystore my_keystore_filename.keystore -alias my_alias_name -keyalg RSA -keysize 2048 -validity 10000

Secondly, I moved the Keystore file to /Build/Android

Thirdly, As I did not have my alias name in my previous file, I had to make correction in distribution settings in project settings android section.

AND LASTLY Make sure in distribution settings under keystore name you add the “.keystore” extension to your keystore file name.

Wow, no man, simply another fellow developer trying to add to this beautiful community. Never thought someone would actually find my answer useful. FREE KARMA! ME LIKE IT!

I believe you are a walking god among humans.

Well, it kept failing when I set it for distribution for no reason, and then I checked and saw that one does not simply package for distribution without that keystore thing.
Then I read that you need to use that command in cmd but no one mentioned that you actually need to put it in a certain directory nor that you need to put the extension ‘.keystore’
I don’t even know how you found out about this.
Not that I plan to publish anything anytime soon but it’s nice to know that you can at least do it and actually work :slight_smile: