Android Packaging For Distribution Failed

Hi Everyone;

I know there are some similar questions on this platform, I checked all the posts and answers, but i still couln’t find a solution. The problem is about packaging the project for Android platform. We will upload it to Google Play Store.

I always get “RunUAT.bat ERROR: AutomationTool was unable to run successfully.” error, when i set the “For Distribution” option enabled in packaging settings. Without setting it enabled, i can package my project successfully to my android device. I tried to upload it that way to Google Play Store, and i get the warning about a Debug Mode Apk upload. The apk must be for distribution.

I tried to package as all Android Versions, Atc, Dxt, Etc1, etc… Still no luck !

So i would be really happy if someone write an answer about this problem. We worked more than a month for our game, but now we are unable to publish it. It’s very disappointing, isn’t it ?

Here is the log file. I uploaded it to Google Drive.

https://drive.google.com/file/d/0B1pYfwuecSDFZHpBVTJBY2tpcnM/edit?usp=sharing

We are using Unreal Engine 4.4.1, And Installer Version.

Waiting for some solution… Thank you for giving time…

Cheers…

ErgunTech

Any ideas ?

Howdy ErgunTech,

Thank you for reporting your issue. I have attempted a repro for this issue but have been unsuccessful so far. I went into the setting and enabled the ‘For Distribution’ checkbox. I was able to package successfully after doing that.

If you load up a new project, enable the checkbox, and package, do you receive that error or does it package for you? Any additional information would be greatly appreciated.

Thanks and have a great day!

Hi Sean,
Thank you for your answer. If i load a pure new project, i still get same error.
I recorded my screen and uploaded, i’ll be happy if you check it too.
I’m also adding the log file of the file i recorded. The log file contains the successful build without for distribution option ticked, and error part.

Here is the video > ScreenRecord - YouTube

Here is the complete log file > https://drive.google.com/file/d/0B1pYfwuecSDFdms4emM5d0dMTVU/edit?usp=sharing

Thank you…

That appears to be the culprit: Program.Main: ERROR: Exception in UnrealBuildTool: ERROR: ant.bat failed [/c “C:\NVPACK\apache-ant-1.8.2/bin/ant.bat” release]

Did you install the Android SDK correctly? (https://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/1/index.html)

Also when packaging for distribution you need to make a few changes to the SDK and your Android Project settings so it is signed and zipaligned properly (although that doesn’t seem to be the error you are getting).

Thanks for reply, I double checked the Android Sdk, i’m following the UE4 documentation for the install and everything seems to be fine.
We still coudn’t find a solution, and it’s really sad that we are not able to share our game after a hard work.

So, the problem appears to be coming from using SDK 20 (aka L or Lollipop). We haven’t upgraded to it yet, but other people are having the same problem:

There is a fix in the Answer to that post that explains how to fix the broken SDK,
Josh

Yeah, I had the same problem Josh Adams below is describing. I removed everything from Android SDK Manager and made sure to only have these installed:

Hope that helps :slight_smile:

Thanks for your answer aragoondoo.

The problem is solved, i uninstalled UE4, and installed again to it’s default directory.
After a fresh install, i directly deleted NVPACK folder and reinstalled the Android SDK packages as in your attachment.
And now it’s working. I can package my project for distribution.

Thank you for all answers. It helped lot.

Cheers.
ErgunTech

thanks for posting this, ive been struggling with this issue for a few days and this post set me in the right directioj