Download

Android Packaging Failed


Hello, I have a game for Android that I’m trying to package so I can test it on a device. I have looked at numerous tutorials and stuff, and they haven’t solved the problem (although I did solve a java_home problem earlier). I’ve done everything from deleting the intermediate and saved folders, to replacing the npk, to disabling armv7, to enabling arm64. I’ve also deleted the android folder in “intermediate”, I’ve run the android.bat, I’ve uninstalled and reinstalled android studios, I’ve reduced the quality to scalable 2d/3d (it was maximum quality before), I don’t know what to do, I’ve spent many hours over the last two weeks trying to figure this out. I’m using UE4 4.26, so no “enable gradle instead of ant”. Does that exit code 1 message have anything to do with anything?

Hi, do you tried not only to install android studio, also to update your SDKs, NDKs, the Grandle thing etc.?
Iam honest when i tell your that i dont know what the problem of your project is, but try to update all the thirdparty android stuff which unreal uses to package your app!

Check also your security software if it blocks something, happened me one time … :smiley: wasted hours before i noticed it

YESSSSSSSS, IT WORKS! :smiley: Finally after 2 weeks of looking (unsuccessfully) for an answer, someone finally answers the question (I’ve had the same question running in the ue4 answerhub for a while now). All I had to do was disable the security software, and rename 2 mis-named files, and it’s working now! Thank you Sky001! :grin: :grin: