Android Packaging Failed: Unknown Error

Hi Guys, I’m trying to Package an Android version of BP_First Person Sample for Gear VR and the Packaging failed with an unknown error. I didn’t change anything of the content or assets (so that cannot be the problem).

I upload the log so if you can help me please.


95543-log.txt (308 KB)

Hi guys again. I tested another project to package and it didn’t worked either. I think the problem is something related with Java or Android Studio.

Please help!

[link text][1]

95655-log.txt (1.15 MB)

Nobody? I tried with different configuration and receive the same error. In the log:

C:\android-sdk-windows\tools\ant\build.xml:888: The following error occurred while executing this line:
C:\android-sdk-windows\tools\ant\build.xml:890: The following error occurred while executing this line:
C:\android-sdk-windows\tools\ant\build.xml:902: The following error occurred while executing this line:
C:\android-sdk-windows\tools\ant\build.xml:283: null returned: 1

Something wrong with the build.xml file in android.

Please try opening your SDK manager in “C:\android-sdk-windows” and you need to dowload all Tools. I would then restart my computer and attempt to build the project.

Let me know if it doesn’t correct the issue, thanks!

Hi , I decided to reinstall all, because when I opened the Android Studio appeared a message about one of the tools wasn’t installed correctly. So probably the problem is what you say. I’m going to finish the reinstall and i’ll comment you. Thanks!!

Hi , I reinstalled everything except one package called “API 23, N preview” that was unable to install because “depend on Missing SDK Platform Android Preview”. What is that mean?

Anyway, I re-packaged the Unreal Project and still not working. It send me the next error:

MainFrameActions: Packaging (Android (ETC2)): BUILD FAILED
MainFrameActions: Packaging (Android (ETC2)): C:\android-sdk-windows\tools\ant\build.xml:649: The following error occurred while executing this line:
MainFrameActions: Packaging (Android (ETC2)): C:\android-sdk-windows\tools\ant\build.xml:694: null returned: 1
MainFrameActions: Packaging (Android (ETC2)): Total time: 17 seconds
MainFrameActions: Packaging (Android (ETC2)): Program.Main: ERROR: AutomationTool terminated with exception: ERROR: cmd.exe failed with args /c “C://apache-ant-1.8.2/bin/ant.bat” debug
MainFrameActions: Packaging (Android (ETC2)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
MainFrameActions: Packaging (Android (ETC2)): Domain_ProcessExit
MainFrameActions: Packaging (Android (ETC2)): copying UAT log files…
MainFrameActions: Packaging (Android (ETC2)): BUILD FAILED

It is little frustrating :frowning: I’ve spend two days trying to test my project and I can’t. What is wrong with Android?

Please help!! Thanks!!

The error that is showing up is: ERROR: cmd.exe failed with args /c "C://apache-ant-1.8.2/bin/ant.bat

This error should be resolved if you installed the TOOLS for the SDK. Did you go to the Tools folder and install the Platform Tools?

By the way, I do not have API 23, N preview installed, so that shouldn’t cause any trouble for you.

Let me know about your Tools folder.

Hi , there is something that I don’t understand. Following the tutorials uploaded in Unreal, I executed “SDK manager.exe” archive inside of “android-sdk-windows” to install everything is needed. When I finished to install everything in that section I assumed that’s all. But if not, How do I install the Platform Tools? I have to run another archive? Thanks!!

Hi , finaly I fixed the problem with this solution: UE 4.7.2 can't pack .apk with Ant - Programming & Scripting - Epic Developer Community Forums

I changed the JAVA folder to C: (to avoid the spaces between “Program File” folder) and It works!!