Download

Android Packaging Error

Hi, I keep getting this error no matter the settings I use in the Android SDK section in the Project Settings, whether I set SDK and API Levels to latest or matchndk and android-19. I have installed CodeWorks for Android 1R5 fully, and set the directories correctly in the Android SDK section in the Project Settings. I have Visual Studio 2015 (Community version) installed as well. I have also setup my android device to for app deployment. But when I try to package the game, I keep getting this error. I just opened a new project with the third person template and tried to package it. I’m using the 4.14 version of the engine.

Please find attached the output log for the attempted build.

Please help.
Thanks.

This is the error:


UATHelper: Packaging (Android (All)): UnrealBuildTool:     [javac] D:\Users\Ibmax\Documents\Unreal Projects\MyProject\Intermediate\Android\APK\src\com\YourCompany\[TEST]\AlarmReceiver.java:17: error: <identifier> expected
UATHelper: Packaging (Android (All)): UnrealBuildTool:     [javac] package com.YourCompany.[TEST];
UATHelper: Packaging (Android (All)): UnrealBuildTool:     [javac]                         ^


You cannot have ] in the package name. I believe you changed the Android project setting package name from com.YourCompany.[PROJECT] to com.YourCompany.[TEST]. [PROJECT] is automatically replaced with the project name (in this case MyProject, so it would be com.YourCompany.MyProject if you had left it unchanged). Just change this back or use com.YourCompany.TEST.

You may need to clean up the project directory by deleting the Intermediate/Android directory after you do this before packaging; sometimes it doesn’t clean it up automatically.

Thanks Chris, that helped. Changing the package name helped, and I was able to package the game successfully. But that was just a new project. I needed to be sure I could package an empty project first. I’ll try packaging my actual game now to see if the same settings will work. Thanks again!

Hi,
So I tried packaging my actual game project, Adrayvia, and after about 3+ hours, the build failed. Please find attached the output log (the complete log is about 9 MB, but I truncated it a lot because of UE4’s forum settings).
I used the same settings as the example project I built. I’m not sure where or what is causing the build to fail. Please help.
Thanks.

I’d recommend posting the full log on AnswerHub. It looks like you have missing assets and are using material features not supported by ES2.

Yeah I just did that. The project was designed for the PC platform originally, but I wanna know if it can run as easily on mobiles, hence the packaging.

Here’s the Dropbox link to the full output log: Dropbox - File Deleted

Here’s the link to the AnswerHub post: Android Packaging Error - D:\NVPACK\android-sdk-windows\tools\ant\build.xml:716 - UE4 AnswerHub

Still need help. Does anyone have some ideas? Please check the log in the link above. Thanks

K, so I finally got it to package and deploy successfully. Thanks Chris!

hi My name is David !!!
In first time excuse me for my basic english.
I have a probllem when i packaging in android asct, I follow the document android quick start… I attached the log.txt.

Log.txt (112 KB)

thanks for everything