Android Packaging Error

When ever I try to package a project I get a packaging error, even with the TappyChicken project.UE 4.15.3 - SDK Settings

LogPlayLevel: **************************************************************************
LogPlayLevel: The "android" command is deprecated.
LogPlayLevel: For manual SDK, AVD, and project management, please use Android Studio.
LogPlayLevel: For command-line tools, use tools\bin\sdkmanager.bat
LogPlayLevel: and tools\bin\avdmanager.bat
LogPlayLevel: **************************************************************************
LogPlayLevel: Invalid or unsupported command "--silent update lib-project --path JavaLibs/downloader_library --target android-19"
LogPlayLevel: Supported commands are:
LogPlayLevel: android list target
LogPlayLevel: android list avd
LogPlayLevel: android list device
LogPlayLevel: android create avd
LogPlayLevel: android move avd
LogPlayLevel: android delete avd
LogPlayLevel: android list sdk
LogPlayLevel: android update sdk
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: ERROR: C:/NVPACK/android-sdk-windows/tools/android.bat failed with args --silent update lib-project --path JavaLibs/downloader_library --target android-19
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 55.436556
LogPlayLevel: BUILD FAILED
PackagingResults:Error: Error Launch failed! Unknown Error

Full Log:[link text][2]

After a lot more searching I’ve fixed the problem .

Dwarf Killer! same issue here. What did you find?? Been trying to sus this one out for days.

The way I used to fix it is to install android tools 19, for what ever reason 27 did not work.Download the android tools 19: tools.rar - Google Drive . goto C:/NVPACK/android-sdk-windows/ name the current “tools” folder “tools1”, then unzip the downloaded tools and put it into the folder.