Android Package Name & admob - com.x.y.z?

Hello,

I created a new project with 4.9, BP only. I noticed an issue with the Android Package Name, if I set it to com.[companyname].[Project].[Sub Project] admob stops displaying ads. Google Play allows me to create and distribute the package to my Alpha testers without any errors. The game plays as expected minus the ads.

Here is the testing I’ve done thus far:

  • Original project - Changed admob unit ID to a newly created unit ID. No change
  • Original project - used tappy chicken unit id. no change
  • Tappy Chicken - used my admob unit ID, deployed to my android. It works fine!
  • New Blank Project A - configured admob unit ID, deployed to my android. It works fine!
  • New Blank Project B - Copied original project content to it, configured admob unit ID, left everything else under project settings alone. It works fine.
  • New Project B - Changed the rest of the project settings to their expected settings, name, desc, company name, version, et cetera. Ads stopped working.
  • New Project C - copied original project content to it, set admob unit ID. It works fine.
  • New Project C - Changed Android Package Name, Store Version, App Display Name. Ads stopped working.
  • New Project C - Changed Android Package Name to com.companyname.project format. It works.
  • Original Project - Changed Android Package Name. It works.

Sorry if it is long winded, just trying to describe my troubleshooting process…

Is this an expected behavior? If so, is it possible to change the package name in Google Play or will I need to create a new Application?

EDIT:
I did verify that my admob and adsense accounts were not blocked/restricted in anyway.

Thanks,
Brumsky

Hey Brumsky,

Are you actually entering “com.[companyname].[Project].[Sub Project]”? We only replace the [PROJECT] portion, everything else should be directly typed in for Android. Example, if your company and subproject are acme and part2, “com.acme.[PROJECT].part2” is what you would enter here.

If it still doesn’t work for you, could you please check the log.cat from the device and see whether or not you’re receiving an error from Ad Mob. Feel free to upload the log.cat file for us to view if you’re not sure how to read the logs.

Looking forward to hearing back from you, thanks!

Samantha,

I actually typed in com.acme.gamename.part2. I see how describing it as “com.[companyname].[Project].[Sub Project]” in my first post could cause confusion - my apologizes.

Admittedly, I already recreated my project in Google Play and have the ads working. I just set the project name to com.acme.GameNamePart2.

Thanks for replying.

Hello,

So the issue is back again. Now using com.acme.GameNamePart2 no longer displays ads. If I change the Android project name within UE, then deploy it to my phone it works again.

I’ve tried creating new admob unit IDs then placing them in UE, with out any luck. I’ve confirmed my admob and adsense accounts are not in violation. I’m unsure if adsense would even affect admob, regardless, neither are in violation.

Here is a copy of my logcat file.

link text

EDIT: Also, I’ve confirmed the ads are not working when the game is played from someone else’s device.

Thanks again,

Brumsky

Hey Brumsky,

I am currently in 4.9.2 and I am using a Nexus 5. I changed the Android package name to ‘com.epicgames.[PROJECT].magic’. The advertisements did appear on the top of the screen.

Is there any reason you took the formatting out of your naming conventions: ‘com.acme.[PROJECT].Part2’?

Thanks!

Hello,

I found the solution to this issue! I was enabling designed for families which is under All Apps, Your App, Pricing & Distribution → Designed for Families. Once I unchecked that it began to work immediately.

Thanks

See this Video

Hello Brumsky
I found the similar issue.
One of my project is on play store and Now I want to config ad-mob in this.
but it is not working in this, but while I changed my package name then it is working fine.

Can you please tell me, whats going wrong with me ?