Android Package Is Too Big

Hey misters. This is my first question and sorry for my English.

I deployed a basic game to Android. I faced with many problems but however i fixed. But i have a big problem, and a big file :slight_smile: There are only some models, textures and shaders in my game but .apk+.obb = 350 mb. I don’t know why. How can i decrease it?

Have you cooked game only with one texture format, or all texture formats? Did you cook game by unreal editor or UFD? if you used unreal editor , have you modified the defaulteditor.ini file, which should contains the map you want to cook, otherwise engine will cook all contents which are included in content dir.

I builded for only ATC format. Cook by editor but really thanks so much. I had never heard that settings in defaulteditor.ini. It compiles all the assets i guess. I will check it.

Hi barbaros:
If you cooked project by editor with package operation. So you should modify the defaulteditor.ini, otherwise the engine will cook all contents of your project, not by reference. Because the cook program will collect the maps that needed to be cooked. If there is not anyone, so the engine will cook all. You can find it in cook codes.
If you cooked project editor with launcher. So I am not sure your engine version. I do not have one test in 4.7 version. I know that there is one issue in 4.6 version. Engine will cook all contents of your project with this operation.
Here is the image that will show you how to set the defaulteditor.ini file.


Also , if you have add some additional assets directionary, if one of them has not valid value(so you’d better not set null as it’s value), the engine also will cook all contents of your project. So wish help you.

That was really helpful. Thanks for reply. I’m using it. Works great.

The above comments are correct about AllMaps.

In 4.8, you’ll be able to edit this in the packaging settings directly in the editor :slight_smile:

I apologize it took so long to get it exposed!