Android Package For Distribution Error (Shipping) - (System cannot find the file specified)


Here is a screenshot of the last page of the output log. *(open in new tab) *
***(I have a feeling that it might be something to do with my keystore, i just created the keystore using a command and then put that keystore into my project/build/android/, is that right?)


Here is the entire ‘Log’ file of the build. (I could not find a log file for the test build i just did so i just copied the text from when it started building until the end, i hope that is ok?)
****Entire Log file](

Here is some screenshots of my situation:







If anyone can help it would be appreciated! I am getting really quite desperate now. Thanks.

Hi ,

Here is a thread that goes into a bit of explanation with respect to your sing.keystore, and just to be on the safe side as I didn’t see it mentioned, here is how to set up your environment variables.

Good luck!

I just did this. what i ended up doing was using the key tool and building from there…
run the command prompt as an admin(7 or above hit start, type cmd then press Ctrl + Shift + enter, hit yes on UAC prompt if there is one.)
then go to the bin directory of the jdk that is installed with the tegra tools. (default is “C:\NVPACK\jdk1.6.0_45\bin”)
Type “keytool -genkey -v -keystore c: emp\REPLACEWITHNAME.keystore
-alias REPLACEWITHALIAS -keyalg RSA -keysize 2048 -validity 10000”
replace c: emp if need be.(or create a temp folder on your c drive)
replace the REPLACEWITHNAME and REPLACEWITHALIAS with something meaningful, like the name of your game(and yes they can be the same)
you will be asked a for a password, type something you will remember. then it will ask for it again.
then it ask you a bunch of questions, answer the as many as you can. (these help determined uniqueness of the signer, so be as specific as you can.)
at the end it will create a file that is named REPLACEWITHNAME.keystore in the c: emp directory(or wherever you told it to put it)
copy the keystore file into your Project’s \Build\Android folder
fill in the Project Settings>Android>Distribution Signing settings with the same info you just typed.
build away.
you may have to manually select the build configuration of ‘Shipping’ and check the ‘For Distribution’ box in the packaging section of the project settings.

Edit: i don’t know if it helps or not, but i have had some issues with only providing a keystore password… what i end up getting better results from is making the Key and Keystore password the same meaning i type the password in twice rather than leaving the key password blank.

Checking “For Distribution” will set the configuration to “Shipping” automatically.

As for the password, you need to enter both a Keystore and Key password when generating it. The comment about leaving Key Password blank meant to assume it was the same as the one you entered for Keystore for the signer to use.