Android Manifest Bug, Prevents launching on device

I have found an unusual Bug when launching to Android found in both 4.19 and 4.20 and I was wondering if anyone has seen it before.

The bug is caused because the Manifest_UFSFiles_android.txt************* file is written incorrectly.

i.e. this line gets wrote

/GearVRControllerMaterial.uasset 2018-07-20T20:43:10.000Z

instead of

Engine/Plugins/Runtime/Oculus/OculusVR/Content/Meshes/GearVRControllerMaterial.uasset 2018-07-20T20:43:10.000Z

I believe this is caused by the localisation toolkit due to localisation being mixed up after this but I have yet to replicate in new project

this is error when trying to launch

Running: C:\NVPACK\android-sdk-windows\platform-tools\adb.exe -s M2HDU18310002543  pull /sdcard/UE4Game/AdvancedVehicleKit/Manifest_NonUFSFiles_Android.txt "D:\Racing-Game\Saved\StagedBuilds\Android_ASTC\Manifest_NonUFSFiles_Android.txt_M2HDU18310002543"
LogPlayLevel: Took 0.050954s to run adb.exe, ExitCode=0

ERROR: System.ArgumentException: Attempt to construct staged filesystem reference from absolute path (/GearVRControllerMaterial.uasset). Staged paths are always relative to the staging root.
LogPlayLevel:           at StagedFileSystemReference..ctor(String InName)

This only occurred on Android 8+ devices.

Log file here LogPlatformFile: Not using cached read wrapperLogInit: Display: RandInit(-7772 -

Link to manifest file here Manifest_UFSFiles_Android.txt_M2HDU18310002543 - Google Drive

If anyone has seen this before I would love to know a solution

Thank you :smiley:

The same thing is happening to me. Except it is only happening to one of my phones the other one it launches on fine. I tried deleting the app off of my phone, restarting it, restarting Unreal, deleting the Staged Build folder and Cooked folder but, nothing. I can’t figure out why it is happening. Would really like to know how to fix this.

I know how to fix this now. Go into phone storage and delete UE4Game folder it’s a broken manifest file from a failed build that is not cleaned up

I figured it out

Delete UE4Game folder in the phones storage the manifest file from a broken build is corrupting the launch process

That worked! Thanks so much.

yes! It worked for me too! I tried to launch while the game was still open in the phone, then it failed and kept failing even after deleting the game and cleaning the project, etc… didnt think about delete the folder, thanks!

it worked thanks a lot!

Worked for me too. Talk about a bug that would have made me go crazy

You… are a G-dsent.

Thank you man!

it worked thanks a lot!