Android launch sometimes won't load maps

This doesn’t happen all the time but when it does it’s annoying. Sometimes when I launch to the phone, the game loads up to the main menu but upon hitting play or any level I get a travel error which is it can’t find the map for some reason so it won’t load. It loads in the editor but not on the phone. The only thing I can think of is data corruption because it only happens once in a while but I have to exit Unreal, delete the app from the phone, relaunch unreal, and relaunch to the phone. And this isn’t always a quick fix. I might have to rinse and repeat a few times. Any thoughts?

This is continuing to happen. Has no one else encountered this?

For anyone else having this issue, this seems to help. Go to Project Settings and turn on “cook everything” under packaging.

A slightly better solution is to go onto Project Settings - > Packaging and then specify the maps you want to cook directly inside “List of maps to include in a packaged build”. As a result, you can cook only what you need.

Unfortunately neither of these are working for me at the moment. I still get travel errors and Invalid URLs. I can’t fix what I don’t understand and I can’t seem to get any viable information on this. I can’t be the only indie moron out here who has encountered this.

I’ve tried wiping the app from the target device both by the uninstall option and the terminal using adb tool, and then rebuilding - which worked initially but is broken again. Subsequent attempts have failed as has the above mentioned. I’ve tried manually adding the links to the levels as you’ve stated, and checking the cook all button. I’ve looked through the logs to get more insight into the exact error but all it says is invalid url but I don’t know why it’s invalid. It doesn’t give me enough information. And when I trace it back, the path is correct. It runs in the editor, it runs in pie, it runs in standalone but not built to the phone. Something’s getting lost in translation.

My problem seems to be that the map name being passed into “Open Level” isn’t the full address of the map. So for instance, if I type in Level1, it will run in the editor but on the package it needs to be /Game/Maps/Level1 for the map name. Now, I say this seems to be the problem because in the data file that stores the list of maps, they are listed with the full address so the name that is grabbed from that list should be the full address. For some reason it isn’t. However, if I type it in manually, it does work on the package. It also needs to be added to the package map list.

Packaged map list

Data list

Open Level

I will post an update with any changes.

I have confirmed that it’s not reading from the data file. I also had it write the level name to the screen when selected and they all report “none” - should I create a new thread for this error?

See below.

Solved (so it seems)

The data file was failing because there were spaces in the column headings. See below:


Coming from a programming background, I almost never use spaces in anything other than strings – I say almost never because Unreal is a little loosy-goosey when it comes to whether it’ll accept spaces or not. As mentioned before, it loaded fine in the editor but failed to read in the packaged game. Removing said spaces from the column headings has solved this issue. For now.

I also, of course, updated the accompanying struct’s member names as well:

I am glad you figured it out.
Just for the record, in case someone else has a similar issue, are you still keeping the maps in the “List of maps to include in a packaged build”?