Android Launch & build errors

Trying to launch TappyChicken (and any other android project) to my Asus Zenfone 5 Android 5.0 Lollipop and I’m getting some errors.

Don’t know what to do!

[Project log][1]

[cmd log][2]

Hey Murilo,

Could you please obtain the verbose from your device when you’re trying to run Tappy Chicken? You should have a similar file path that will provide you with the program ‘Monitor.bat’. Please locate: C:\android-sdk-windows\tools Once you have, make sure that you highlight all of the so that it captures them when you’re trying to save them to your computer.

Looking forward to hearing back from you, thanks!

Hi ! Thanks for the help!

I dont understand how I get these verbose .

And sorry for taking so long to reply!

Please locate Monitor.bat which is typically in a similar file place as: C:\android-sdk-windows\tools. Once you have Monitor.bat open, please then connect your device and attempt to run the project. At this point, should be populating in Monitor.bat which you can then highlight. The highlighted section is the only section that will save so please make sure that you highlight the whole entire log and save it.

[Mobile Development Troubleshooting Guide][1]


A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums


[Verbose log][1]

I don’t know if I did it right

I ran the app on the phone and tried to pick only the of interest

Thank you!

63872-verbose+log.txt (25.1 KB)

Thanks for providing me with the .

  • Were these all of the that showed up in Monitor.bat?
  • Did you allow your computer to be trusted on your device?
  • Have you been able to reproduce this with any other version of the engine, such as 4.10 Previews?
  • Did you attempt to push these projects to other devices, or only the Zenfone 5?

Looking forward to hearing back from you, thanks!

  • Those were a piece of the log output I could get, because the console wouldn’t stop showing new . They are a piece of the output where I started the app and waited for it to show the fail message. This log covers this range. I don’t know if I did it right.

  • Yes, I allow everytime i connect it.

  • I tried to build it in 4.8, 4.9 and just tried with 4.10 preview 3, but also failed.

  • I also tried with Galaxy Win2 running Android 4.4.4 Kitkat.


In Monitor.bat, can you get all of the for me? You can actually make a filter in Monitor.bat that filters out UE4 and UE4 Debug. Here is a picture as an example of what Monitor.bat would look like after you added the filters in.

Once you’ve set up the filters, copy all of the before and after the app crash. Please include the from both devices that you tried.

If you receive any failures from the editor, please include those too.

Here, I think i got it : [LOG][1]

The other device belongs to a friend of mine. Unfurtunately I think I won’t have access to it in the near future (this week).

I’ll try to get some other device if you judge necessary.

Thanks for the help!

64605-log.txt (2.13 KB)

So I have looked over all of the you have provided thus far, as has an Android Developer. We did not see any crashes within the verbose log.

The only thing that we saw that may be an issue is the following:

10-24 00:08:10.901: E/GooglePlayServicesUtil(1142): The  Play services resources were not found. Check your project configuration to ensure that the resources are included.

Go ahead and try to turn off Play Support in Android Project Settings if you have that on. Let me know what happens, provide the if possible.

Thank you!

It was already off. I tried to turn it on and launch but got the same result.

Also there are these that are generated when I simply press the launch button (without using the advanced options)

There are some Metadata mismatch warnings in those.


64855-log+(2).txt (749 KB)

So launching is basically just not working for you. Are you able to get any other projects to launch onto your device? What about packaging your project, does that allow you to push the packaged project to your device?

Please include any you have, if you attempt to package and it does not work.

Hey ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

Well I tried all that in the past days and nothing seems to work at all… I also tried to download some games on the Play Store and none of them worked (including Tappy Chicken), so I’m assuming that UE4 currently doesn’t support my phone. Thanks for the amazing support, . I hope that in a future release the device compatibility can be bigger on the engine! I’m really looking foward onto that. In the meantime I can work with PC-only projects.

Once again, thanks a lot for the help!

You’re very welcome. Please let us know if you have any further questions or concerns. When the release of 4.10 actually happens, I’d try again, just in case. I know our Android Developers have worked hard on making some changes for 4.10. I can’t guarantee that it will work on that specific device, but it’s worth trying.

Have a great one!

Thanks! I’ll give it a try for sure!