Android in app purchase bug

Hello, I have an app on beta in the play. The app is done the only thing left is the in-app purchases.

I have the following code:

A friend of mine tried buying my product, the money went to my merchant account, but the On Success node didn’t go on, so he didn’t get the “dragondust” variable, instead the On Failure node hit, even though I got the money.

My friend has android 5.0, and I compiled with ndk and sdk, don’t know if that has something do with it.

Is this a bug or am I doing something wrong?

Hey ,

  • Have you tested this on more than one device?
  • Do you have any from the Android device that could be shared?
  • Are you able to test the shopping feature in mobile preview with a breakpoint where you believe it’s not triggering?
  • Does this happen on any other project you test this in?

If you’re not sure how to obtain off of your Android device, all you need to do is go here: C:\android-sdk-windows\tools and run ‘Monitor.bat’ while your project is running.

Looking forward to hearing back from you, thanks!

I have not tested this in more devices, and I don’t have access to any because the purchase was made remotely from another phone (moto g 2015, android 5.0.1). I can’t buy the in-app purchase because I am the publisher and it won’t let me, I’m not sure how to use test product id though.
i was wondering if there is anything wrong with the blueprint, or a in-app purchase bug in 4.8, or a compatibility error (game made with ndk,sdk 19). Could it be one of these? If no I can proceed testing it to many devices.

I tested it on another device 4.4 and the same problem occurred, on failure node appeared, and in both cases, when i try to buy again,I automatically get on failure node without even showing the price or asking for confirmation.
This time I tried with consumable tick off.

Hey ,

We are looking into this further for you and will update you as soon as we can, thanks!

The issue that you’re experiencing is very similar to this [AnswerHub][1] post. You may learn additional information by reviewing that post. Please keep in mind that a bug has been entered for this issue: UE-22157. Please feel free to check back in a couple of weeks to see our progress on this bug report.

Thank you!

Make In-App purchase works weird - Programming & Scripting - Epic Developer Community Forums