Android game running with black screen


I could successfully build and launch the First Person Template but besides the hud everything is pitch black. The virtual joysticks are working and sound is played when the display is tapped.

The device is an Asus Memo Pad fhd 10. It has an Intel® Atom™ Z2560 Dual-Core, 1.6 GHz and
a PowerVR SGX 544MP Gpu.

The Tappy Chicken runs perfectly smooth and everything is clearly visible. Every other Demo project however has this issue. I tried deactivating all the post-processing effects and disabled mobile hdr but no success. I have attached the complete log here: [Log][2].

Some lines caught my attention:


LogPackageDependencyInfo:Display: Package Info not found for …/…/…/Engine/GlobalShaderCache-GLSL_ES2!

For all my assets in the content folder are the Package Infos missing

and 317…374

LogPackageDependencyInfo:Display: Package Info not found for …/…/…/…/…/Users/ned8si/Documents/Unreal Projects/MyProject3/Content/Maps/Example_Map!

LogCookCommandlet:Display: Failed to find depedency timestamp for: …/…/…/…/…/Users/ned8si/Documents/Unreal Projects/MyProject3/Content/Maps/Example_Map.umap

LogCookCommandlet:Display: Cooking /Game/Maps/Example_Map → C:/Users/ned8si/Documents/Unreal Projects/MyProject3/Saved/Sandboxes/Cooked-Android/MyProject3/Content/Maps/Example_Map.umap

I’m pretty much stuck at this point maybe somebody could push me in the right direction.
Thank you

Dave, the problem is what you deploy too. Android ATC ETC ETC1 Dxt Pvrtc. I’m going off the top of my head on those acronyms. Each devise is cabilble of some or all. I don’t know that device but try Dxt ect2 or Pvrtc. My nexus 7 can’t do Dxt but etc2 just fine. My shield does Dxt but not etc2 both end up with similar result. It the shaders applied not every device can do everything. Check the official documents.

Thanks for reply but i tried all the texture compression modes there are… I’m using PVRTC because it’s a PowerVR gpu but i also tried ETC2 which should be guaranteed to be supported (The tablet is GLES 3.0 capable)

i’m feeling a litte bit retarded but Mobile HDR was left true…
I unchecked it but i did not press the set as default button therefore it was never actually written in the defaultengine.ini file… In the project settings it appeared to be not selected but the variable still was set to true…

a whole day wasted by nothing but a false bit… programming!

I was facing this problem and the only solution was to add a huge light mass importance volume (10000 x 10000 x 10000). I am having trouble running my game on android too.

am having the issue for building mobile apk, when i try in play mode the cam goes upword from the mesh and am unable to go inside the mesh room ,can anyone tell me how to solve this

Wonderful great going, I love your work and look forward for more work from your side. I am a regular visitor of this site and by now have suggested many people. visit website

How exactly have you turned off the Mobile HDR at the end !?
I have unchecked it from engine project settings but my game is still black on android.