Android game not opening levels after packaging

Hello, I looked up for a solution to my problem all over but nothing fixed the issue, so as a last resort I’m posting here so maybe someone from the community can help me figure it out:

The short story is:

I have an Android game in UE 4.24.3, its a simple side scroller where you pick a map, pick a character, collect some gems and shoot some enemies, thats it for gameplay.

Everything works fine while playing on Selected Viewport, Mobile preview ES3.1, Standalone game, whatever, it works.

After packaging for Android Multi, moving the apk to my smartphone and successfully installing the game, I run the game, whatever map I select in Game Default Map, the HUD buttons that should do something and open another level just make the screen blink and nothing happens.

So the problem is, Open Level is not working in any of the HUDs, wheter is it to select a language or open a gameplay map;

I have Android SDK License and Google Play Services properly configured, and Android SDK paths all set.

What did I tried as solution for this problem?

#1 Project Settings > Packaging > List of maps to include in a packaged build > Added all maps and checked for misspelling;

#2 Project Settings > Packaging > Additional non-asset directories to package > Added map folder to it; (I saw a thread that this was the solution to the same problem basically)

#3 Praying for enlightenment…

The long story now:

I have 5 Maps:

#1 for language selection: Level BP opens HUD widget, 2 buttons with flags to change Language and open next level, this is the first map to open in the game but can also be opened through the options menu;

Level BP:

Language HUD Widget Interface:

Language HUD Widget Code:

#2 for main menu: Level BP opens HUD widget, Play button open HUD for selecting gameplay map (this HUD opens fine, has code to open other Maps but doesn’t), Options button to open HUD for credits and return to Language Selection Map (this HUD opens fine, has code to open language selection map but doesn’t), and Quit button to quit game;

Level BP:

MainMenu HUD Widget Interface:

MainMenuHUD Widget Code:

Map Selection HUD Widget Code:

Options HUD Widget Code:

The other 3 Maps are for gameplay, and I don’t know if there is any problem with them, because I can never get to them…

Here is the main Player Controller used by the game and the code responsible for opening all the HUDs:

Edit1: Don’t worry about the Exec not connected to Set input mode UI only, I was testing alot to try and solve this.
If anymore code or configs are required, I can post here, please help me… I promise to never try and make an Android game again.


Hi, I’m using Google Translate to read your message.

I’ve had a similar problem with opening Level on Android.

In my case, the textures I used in Tilemap and Sprites were very large.

What I did was open the images in Photoshop and reduce it from 1024x1024 to a size of 128x128, so the level started to open normally.