Android game crashing when Google Play services enabled


We’re seeing a weird issue where ~ 1 / 3 of our beta group playing the game on Android have the game consistently (although some people can get past this is they persist 4-6 times) crash on them. We noticed this a few weeks back and thought it was related to a bad Google Play services setup, so we turned the game services off (which completely fixed the problem), deleted them and rebuilt/re-linked them. But now that we’ve turn the game services back on, we’re still seeing the same problem.

I goggle around about this, and the best solution I came up with was to rebuild the entire project from scratch. So that’s what I’ve done: Made a brand new project, copied over the content and re-setup all of the project settings / config files. Didn’t help (new build pushed to the store a few hours ago is still crashing).

Annoyingly, it’s not happening on any of our test devices either, so we can’t trial and error it here. Someone let me know that their device is a Wiko Highway Signs, running Android 4.4.2

Any ideas?

For the record: The devices that don’t have this problem, work perfectly (achievements, leaderboards, player registration, sign-in, permissions all work as expected). It’s all or nothing. It either crashes, or it doesn’t.

Oh, to clarifty - the crash happens just as the google play sign-in occurs. They get asked to choose a user to sign in with, they OK the selection, they see the ‘loading’ icon spinning for Google Play then… nothing - App’s gone.

Tried the fix from this post this morning. Didn’t help.

Hello Triblade,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Could you provide a list of the devices that are experiencing these issues?
  2. Would it be possible for you to provide a sample project that exhibits the issue that you are experiencing?
  3. Could you acquire and provide the crash logs from the devices that are having this issue?

Hi, thanks for the reply.

  1. So the Wiko Highway Signs (running Android 4.4.2) is obviously one of them. I’m trying to get a list of other devices from the people who have reported issues. I’ll update as they provide information back to me.

I do have a report of a ‘Samsung S5 running Android 5.0’ that wasn’t working originally, but is now, so something we’ve done over the last few weeks has fixed the issue for them (Maybe adding ‘android.permission.INTERACT_ACROSS_USERS’, maybe we need additional permissions?)

  1. Yes, we can give you the entire project as it is. Where can I put it?

Also, the game’s in live open BETA, so you literally pull the current build down yourself if need be: Sign in - Google Accounts

  1. Is it even possible to pull a crash log from a distributed build? If so, what’s a quick a clean method for me to provide to people to do so (bearing in mind, most of these people aren’t tech-savvy)?

Also, our latest BETA has the option to skip the sign in of Google Play completely. I’ve now had three separate reports that people who experience the crash can skip the sign in and play the game without issues.

If you would like to send the project you can do so in private message to me on the forums. You can share it via google drive or drop box.

Another one of the devices that consistently can’t log in is an Alcatel Pixi 4013x running Kitkat.

I’ve sent you a PM on the forums with details on to grab the project.

Hello Triblade,

After looking through the project that was sent I was able to narrow down the cause of the issue. I have written up a report ( UE-24770) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for you time and information.

Make it a great day

Hi Rudy,

Thanks for chasing this up. We were looking to ship this project just before Christmas (we failed for other reasons) and are now aiming for the first/second week of January. But this issue is now a blocker for us releasing on Android. Are you able to give us some information as what the cause of the problem is and/or, we hope, a work around?

Hello Triblade,

I found that calling the node “Show External login UI” with the with the Enable Google play support checked to true will cause this crash on the device. I hope that this information helps. I do not currently have a workaround for this issue.

FYI, as this is blocking the above project, we decided to return to a previous one.

We’ve now purchased an Alcatel Pixi 4013x for ourselves, confirmed that phone also experiences the crash. Then we tried said other project, which also crashes (on both 4.9 and 4.10). So it appears to be more wide-spread than just a single project.

Hello Triblade,

Thank you for the additional information, I was able to reproduce this issue in a clean project. However, I will add the relevant information from you reply to the report.

Make it a great day

Hey Rudy,

Has their been any progress on this issue? Do we have an ETA on a fix?

I went ahead and double checked on this issue for you. This issue has been resolved internally and this solution will be available in a later release of the engine. I have provided a link to the github commit in case you would like to try cherry picking the solution. I hope this information helps.

Commit link:

Make it a great day

Hi again,

So I grabbed the latest version of the engine (4.11.P2; 97c8d3ef55e869e17ef149903eae2a33101381c9), rebuilt everything from scratch, built a deployment ETC1 build, put it on the Alcatel Pixie 4013x and it still crashes most of the time.

Bear in mind this was done in a clean folder, so no prior intermediate/saved folders, and I cleared off existing versions of the game on the device (+ emptied the misc storage folder).

Are there any other devices other than the Alcatel Pixie 4013x that are experiencing this crash?

I can only re-iterate what I’ve said previously: Someone reported the same thing on a “Wiko Highway Signs”. Other people had been seeing intermediate issues which may or may not have vanished more recently (not sure which devices – A Samsung S5 was mentioned).

Whether this recent code change fixes it on other devices, I have no idea. It doesn’t happen on three of our devices here, but we can’t really afford to keep buying phones to test on. We could potentially update our BETA build in a few days time (we’re not in a state where we can do so right now) and hope that the guy with the Wiko is available to re-test it for us, but I’m not expecting a different result to the Alcatel. One of our projects functioned on the Alcatel for a long while (I believe it was across UE4.7 and 4.8) before this crash became an issue.


Is there any new information on this issue?