Download

Android exportation to the Play store market error

Hello,

I have created an game with UE4 and it work when I click the little tab beside launch and then my phone. I can export the app to an .apk and .obb files but when I upload it to the developpers console, it says that the apk is a debugable apk and the key is not valid:

English version of the image:
Failed to upload

You uploaded a debuggable APK file. For security reasons, you must disable debugging before it can be published in the Google Play store. Learn more about débogables APK files.

You uploaded an APK file with a debug mode signature. You must create an APK file with a signature output version mode. Read more about certificates signatures

You uploaded an APK file whose certificate is not yet valid. You must create an APK file with a valid certificate. Read more about certificates signatures

I have created a storekey with the java\bin and with the keytool command(
keytool -genkey -v -keystore my-release-key.keystore -alias alias_name -keyalg RSA -keysize 2048 -validity 10000). I putted them in the <Game>\Build\Android as asked and putted the right stuff in there but still doesn’t work…

Anyways thanks for your help,
TechKnowCase

Did you tick “For Distribution” in Package settings? and enter in your key details in SigningConfig.xml ?

yes its on Shipping and how do you do the second part?

were is the file*

nvm I have created it in the Engine\Build\Andoid\java … I have copied it and paste it from this page… can you just make sure its Aokay? pls ouya-sdk-examples/SigningConfig.xml at master · ouya/ouya-sdk-examples · GitHub

now when I try to export the game it give me this error: RunUAT.bat ERROR: AutomationTool was unable to run successfully. ; BUILD FAILED ;

Hi all, build failure for Android when a package is marked ‘for distribution’ is a known issue that is currently being investigated (UE-11350).

@wittlief when I have installed UE the SigningConfig.xml file wasn’t there. IDK if you guys can fix this or what…

Well, it’s bugged, so we’re gonna give it our best shot :smiley: I will definitely report back what is found ASAP.

Did you guys fixed it?

https://answers.unrealengine.com/questions/177637/47-android-shipping-crash-on-launch.html

The answer from dredok might help you.

Looking at the status of the issue it is not completed, but is slated to be included in the 4.7.4 hotfix release, for which I do not have a date, unfortunately. It is the next scheduled hotfix, so it should not be that long.

I don’t have a lot of details about the issue, but it apparently has something to do with mismatching project and package names.

okay thanks :'D