Android Drop Frames since 4.9.2 Update


I was ready to ship my game off to Google and Apple for their app stores when I ran into an issue with testing the final version of my game on my Galaxy S5. I recently updated UE to 4.9.2 and noticed that after doing so my game drops frames well below 30 fps, when it normally would play at ~60 fps. The game isn’t unplayable, but it is unenjoyable, and frustrating. I’ve already made beta test builds for both app stores so I know I have my keystore and provisions setup correctly and I already have the project set to package for Shipping/Distribution.

I’ve deployed to two different Galaxy S5s and one Galaxy S6 Edge, all exhibit the same problem. I opened a backup project of my game from mid September and deployed it to my phone and I saw the same frame dropping issue, and I know that version worked perfectly back in September. This issue was discovered this past Monday when I updated to 4.9.2, so I wasn’t sure if there was something that I need to modify with my .uproject file? It’s currently set to version 4.9. I’ve even tried installing UE4 on another machine and deploying from a clean environment, but I still get low FPS.

Lastly, I notice that when I launch the game to my phone from the engine it returns no unusual warnings or errors. But if I launch it to my phone a second time I get this warning for every single asset in my game “LogPackageDependencyInfo:Display: Package Info not found for …/…/…/[GAME]/Content/Actors/GameMusic!” It still gets deployed to my phone, but I just get these warnings that I wasn’t familiar with. This whole game is built using blueprints.

Thank you for the help! This is the last piece I need to figure out before I can submit my game!