Android Distribution Shipping don't work on some device but Shipping (For distribution unchecked) work well


After few days of nightmares, I’m coming up here for asking for helps !
I can’t stand it anymore with this weird thing !

Description :

1/ When I package my project for android in Shipping mode and without For Distribution,

I can install it on my device with the .bat and play it. It works good !

I tried on two other android device, the same ! Great !

2/ When I package it in shipping mode with “For Distribution” activated.

I can install it directly on my device or via Google Play Store.

But when I try to play it, I see a black screen for like one second and then quit and tell me the app has to close.

→ On the two other devices, the app seems to work great !

→ And even more weird, sometimes, it works on my device but like 1 on ten times… isn’t that really weird ?!

(For information, the device where it’s not really working well is a Xiaomi mi A2 Lite with the latest update, Android 9 and it was the one I used for testing and launching via UE4 Editor).

I tried many different settings and many different package in order to make it work “normally” in Distrbution-shipping mode on this device, but I really don’t have a clue to what I can do. I read many other subjects like this on this forum and try some answers but it seems not to work…

Here is a logcat I export with the “adb logcat > logfile.txt” command but I don’t really find some clue in it.
If someone know better how to read it and can get me somewhere with it, I’ld be eternally grateful ! haha !

Hopefully, someone find something !

link text