Android deploy is not supported on Mac OS?

I’ve set up environment variables as stated in documentation (Setting Up Unreal Engine Projects for Android Development | Unreal Engine Documentation)
ANDROID_HOME, JAVA_HOME, NDKROOT, ANT_HOME (via both /etc/launchd.conf and environment.plist)
Restarted OS, and in terminal i can see all of these variables, but in Unreal Editor in Device Manager i not see my device. Moreover in menu File->Package Project listed only iOS and Mac and no Android.

Device listed in adb devices -l and work in ADT and Unity.

$adb devices -l

List of devices attached

4100b9d1f9ef7000 device usb:1D130000 product:craterxx model:GT_I9152 device:crater

Configuration: MacOS 10.9.2 x64 (iMac 2012), installed Oracle JDK 1.7, ADT 22.2.1, Ant 1.9.3, UE4

Just installed UE4 on Windows and see that menu system is completely different about Android. Menu File->Package Project contains Android even if i do not set any of environment variables. Also Project Settings contains Platforms: Windows and Android. On Mac OS these menu items is absent. In Device Manager there ability to add unlisted device for Android platform and it not presence on Mac OS version. So as i understand there is no support for Android on Mac OS platform.

Hey megahard,

Sorry for your lost time. Currently Mac OS cannot build to Android, but it is something we’re working on. It has already been started but we don’t know exactly how long it will take. Glad to hear you’re able to package it on your PC, though! For now, you can copy your project to a PC (or Boot Camp partition on a Mac), open the .uproject file in Windows editor and use it to package the game.

Guys, it’s about half a year to this post. Any progress?

Is this still the case with 4.7.2?

Hi badweasel,

With the 4.7 release, Mac users can now build, cook and package for Android, as well as deploy to Android devices from the editor or command-line.

You will need Java for OS X and the Android SDK (which can be installed using the TADP installer in Engine/Extras/Android).
After installing, either restart the editor, or set paths to the SDK in the new Android SDK section in Project Settings.