Android crash because of static mesh

Whenever I try to launch my game on a device, it will immediately crash.

I have narrowed down the cause to a simple static mesh that I am using. If I have the mesh imported, but not used the game will launch fine, however if I place the mesh on my level, or if I use it as the mesh for a spline and try to deploy, the game will crash on launch.

The game works fine for in editor testing, it only crashes on the android device. The mesh is a simple 3 sided cylinder with about 5 segments, it is designed to be used as the mesh for a spline.

I got the error log from ADM, and it says something about a nav mesh… I’m not using any sort of navigation in my game but I also tried adding collision to the mesh and a navigation volume to the map with no luck.

12-17 18:16:04.619: D/UE4(25045): [2015.12.18-02.16.04:632][  0]LogInit: Version: 4.10.0-2758231+++depot+UE4-Releases+4.10
12-17 18:16:04.619: D/UE4(25045): [2015.12.18-02.16.04:632][  0]LogInit: Branch Name: ++depot+UE4-Releases+4.10
12-17 18:16:04.749: D/UE4(25045): [2015.12.18-02.16.04:755][  0]LogAnalytics: [UEGame.UnrealEngine.Release|AB7E70B043F046F9888B0BBB78384132|UE4Game] APIServer = AppVersion = 4.10.0-2758231+++depot+UE4-Releases+4.10
12-17 18:16:04.749: D/UE4(25045): [2015.12.18-02.16.04:755][  0]LogAnalytics: [UEGame.UnrealEngine.Release|AB7E70B043F046F9888B0BBB78384132|UE4Game] SetUserId ANON-002DEF97-2F0C-1303-000F-00B8EC74A8FC
12-17 18:16:04.749: D/UE4(25045): [2015.12.18-02.16.04:755][  0]LogAnalytics: [UEGame.UnrealEngine.Release|AB7E70B043F046F9888B0BBB78384132|UE4Game] AnalyticsET::StartSession
12-17 18:16:04.859: D/UE4(25045): Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Engine\Private\AI\Navigation\NavCollision.cpp] [Line: 440] 
12-17 18:16:04.859: D/UE4(25045): [2015.12.18-02.16.04:866][  0]Assertion failed: Assertion failed:  [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Engine\Private\AI\Navigation\NavCollision.cpp] [Line: 440]

Could you please try to delete your ‘Intermediate’ and ‘Saved’ folders from your project and let me know whether or not you’re running into the same issue? Also, could you tell me if this is happening on any project that’s using navigational mesh, or is it simply this project?

Looking forward to hearing back from you, thanks!

Thanks, that worked! For the record, the project didn’t have a nav mesh, or collision for the imported static mesh. I tried adding both the nav mesh and collision with no luck, but deleting the folders and re deploying the game worked!

I have the same issue, do I need to delete ‘Intermediate’ and ‘Saved’ folders each time I import new static mash and deploy ?

If you’re running into similar issues and deleting these folders helps resolve the issue, it may be best to include that into your normal routine. These are folders with content that is typically updated with each save.

I hope this helps!