Android Configure Now Error!

I try to clicked “Configure Now” which it’s in Platforms->Android->APKPackaging->Configure Now
but there is a error “could not overwrite project properties file” be showed.
So does anybody know what’s the problem with it?

Hello -

Can you go into your Project Folder, Build, Android and look for the file and ensure that it is not set to Read Only?

Thank You

Eric Ketchum

Hi ryuikuya -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you -

Eric Ketchum

For me the Android folder is empty

I finally worked out .U need to build android in source code first

I’m about a week trying to get Android output of your project, but unfortunately, I received an error
Project Settings button in the configur now I
can not over write file prperties
I have received and by no means can I fix.
I am kickoff and stay in the game engine will leave open

I’m really stuck in the “Configure Now” issue as well. Could you please explain how to build android in the source code. Just building the project from Visual Studio isn’t enough apparently.

@ryuikuya would you mind explaining how to “build android in source code first”? As far as I see, the UE source code does not include a visual studio Android target for making builds: just win32, win64 and mac.

@ryuikuya I get stuck in this issue as well. Could you explain how to “build android in source code first” in further detail? Really appreciate your help :slight_smile:

@Lovecraft_K :diamonds::diamonds:
yeah, I need to build android in source code first.
But…actually there is no Android option.
Could you give me any suggestion?
Really appreciate :slight_smile:


I have manually added file to Build/Android and it worked for me !

Finally I figured out by running Setup.bat –-include=Android. It’s because of lack of prerequisites and dependencies for android platform.

Choosing Android I am getting an ugly error…

Severity Code Description Project File Line Suppression State
Error MSB3075 The command “…..\Build\BatchFiles\Build.bat UE4Editor Android Development -WaitMutex -FromMsBuild” exited with code 5. Please verify that you have sufficient rights to run this command. UE4 C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets 44

Any ideas?

this worked for me as well, adding a new empty file in Build/Android