Download

Android Compile Errors

Hello, since some time ago i noticed when I compile in visual studio or try to package game on engine i get these errors:

Visual studio:

37a85169e34030d2f55dbbaebfa43da0b34a66e8.png

Ue4 When i try to Package Game [Android All] (not compiling, compile works I can launch game on phone):

50651219f20fdd7427a5aa9c21aac923b71f2f68.png
36dd050ccd661176a16e7936baf5c73c66254cf9.png

Hopefully someone could help me, I’ve tried many things, none worked!

Hi Sampuig12,

Go into your project’s Config folder and make an Android folder. Create an AndroidEngine.ini here and put the following in it:


[Advertising]
DefaultProviderName=AndroidAdvertising

[OnlineSubsystem]
DefaultPlatformService=GooglePlay

[OnlineSubsystemGooglePlay.Store]
bSupportsInAppPurchasing=True


And remove these from the DefaultEngine.ini. This way only Android target will include them.

Hey there, thank you very much for the answer, my post did not have much succes although compiling for release is a major problem, so thanks for taking the time to help.

I have done what you said above, and sadly this did not affect compilation.

The errors that I am currently getting in visual studio :

26fcb9f371b64cd3f846c320b87f6654e3a20fe8.png

In editor :
(Alot of java errors for some reason.
67bd62af65c63a07af484555f08a70af38bc1af8.png
41f436461786f0772418eddb1e7f1dfadc7c44c1.png

Hi Sampuig12,

Full text logs are more useful than screenshots; I can only see part of the problem. Try Debug or Development, not DebugGame.

Sure i’ll provide you a link ASAP

Visual studio log:

Ue4 Logs:

Hi Sampuig12,

Okay, a couple of things I see. Use Development instead of DevelopmentGame for Android. It also looks like you have an odd package name. Usually you would use “com.mycompany.productname”, I don’t think it likes you naming it ending with .package. Change the name and clear out your project’s Intermediate and Build/Android/src directories before trying to package again; this will make sure you don’t have duplicates of the generated downloader files with the wrong package name left over.

Also, it looks like the Victory plugin may be out of date? The line numbers don’t match the GitHub version and it likely needs recompiling.

Alrioght i’ll try all of that, be back in 5, thanks alot for the answer.

And the pluggin should be up to date, I am using :

for 4.10

Ok, bad news, sadly, nothing has changed, i don’t get it, i’ve tried alot of things, there must be a way to fix this surely?

Just in case you would need this:

42cee430f8fe0a8172eaa24f45e8add0caed3724.png

454e9c81fc9b42ba46747206e3187e6844c9a492.png

fad85b24977f6769c681e30cd60f19b12eaf52e0.png

d45946ab817c248d04a3ff6c6358037f6d8c0ab9.png

oh well i found out something while posting these pics, the environement vars in path, ant.bat path is wrong version, just changing that to see if it works

Edit: Did not work.

Bumping this.

Hey there, I Reinstalled UE4 + Visual Studio(fixed a bug to generate VS files on right click)

I am still getting 1 error, a new one, i can’t figure out how to fix it.

In UE4 when i want to launch on android:

And in Visual Studio (2015):

Thank you.

Well I fixed it.

Repaired visual studio application.
Repaired epic games application.
Updated rama’s plugin.
Deleted Intermidiate Folder.
Generated Visual Studio Files.

This thread AND this one : https://forums.unrealengine.com/showthread.php?100176-Urgent-Launching-on-Android-And-Visual-Studio-Errors can be closed.

Thank you.