Android: can't package: Intermediate/Android/APK\gradle\rungradle.bat" :app:assembleDebug

UATHelper: Packaging (Android (ASTC)): ERROR: cmd.exe failed with args /c “C:\UE4\UE4_androidVR\Intermediate/Android/APK\gradle\rungradle.bat” :app:assembleDebug

Good afternoon, help me, please, I can not pack a project for Android
I don’t know what to do: I read a few questions with the same error but never found a solution …


Anyone solves this problem?

The cause is that Google recently changed the license agreement, but as of UE 4.21, it has not been able to cope with the change.

Try this

1.DL →
2.overwrite to 「~/Engine/Source/ThirdParty/Android/package.xml」
3.Launch UE4
4.push to 「project settinh > Android > Accept SDK License」button

getting page not found for

can you make a gist of xml page

sorry,i forgot this.
you need to be Authorized github account to epic games to connect to this URL.

how to >

even in 4.22,im unable to build apk.same graddle error,accepted sdk license.

Same here. I tried everything already so it led me to reinstall everything and then it led me back to the same error. People this is HUGE… Error…Epic…like…HELP…

Have you able to get some kinda fix…

need to downgrade android build tools .i used version 28.0.3. i dont even tried new build tools version.
first update to latest build tools,if dont work …downgrade to 28.

downgrading android build tools to version 28.0.3 works .you can do it in android sdk manager .reinstalling android sdk will just update build tools to its latest .which wont work for unreal builds.

  1. go to C:\ Users \ {yourusername} \ .gradle

  1. delete caches and daemon foulders! if you cant see them set show hidden files

  1. open your project and try to package

An easy, yet annoying workaround for me is to delete /Intermediate/Android folder in the project. It solves the issue for me, but it has to be done almost every time I launch a new build.

thanks! this worked for me!

Thank you, this was the solution for me as well!

Awesome Dude!

Also Its Safe To Delete

Actually Didn’t Work, I Have To Now Use The New Nvidia Codeworks Setup On UE 4.26 Rather Then My Custom Set Up, Lets See

Using The Nvidia Code Works With Only NDK Being 23 Beta

Just Realized For Some Reason OculusVR And SteamVR Are Enabled, That Is Said To Cause Issues, Unenabled Lets See How It Goes, These Were Auto Enabled And On Mobile Proj, BRU

Didn’t Work, Further Research Needed