Android build fails

I compiled 4.8 source in both ‘Development Editor’ and ‘Development’ separately.Out of which Development Editor didnt allow me to package for any platform but ‘Devlopment’ allowed for only win64 packaging and not android.

1.Automation tool unable to run
2.missing reciept ‘’ error

are what i got but have no idea about them.

I last used 4.7 binary version which was able to package only for win 64 and Android ETC2.It confirms Android sdk is set up properly.

here is complete log.
link text


For Engine, which were built from Git sources, you need build additional libs for Android. In VS 2013 select Development Editor/ Android-Tegra build configuration and select Build. And try to create package for android again.

There is no such option as Development Editor/ Android-Tegra in VS community edition.

VS solution always generated with this configuration.


i dont have that in my list.

Hi lazysnake61,

Do you have the TADP version of Android SDK (now called NVIDIA AndroidWorks) , or the stand alone Android SDK?

stand alone

i also downloaded TADP version but it still fails.

Can you see Tegra-Android as a selection in Visual Studio, now?

After setting up TADP sdk, i ran setup.bat and when prompted about certain files modification i chose no.After that i ran generateprojectfiles,bat and then used Build UE4 in VS with Development config and Android platform. I can export to Android now…strange.

No the tegra option is not in VS list but it is listed in the window that opens after selecting from the platform list.However selecting it gives error “operation could not be completed”.

btw i can package only development build (not shipping) build now.