Android Build Failed

I downloaded the source code of UE4 and build it with a configuration of Win64 Development Editor. Then I followed the steps of Android Quick Start but failed to build a version for Android. In the log, it said “PackagingResults:Error: Error Launch failed! Unknown Error”. How can I fix it?[link text][1]

89907-log.txt (770 KB)

Hey Isatin,

Could you please show me a screenshot of your Android SDK? Are you able to package a newly created template, or do you receive the same errors?


Hi ,

Thanks for your reply.
Did you mean my folder of Android SDK or Android SDK Manager? Anyway, attached you can find both.
I just followed the instructions in Anroid Quick Start and built a template project of ThirdPerson on a virtual device of but failed. There are some warnings in the log but I am not sure if they were related to the build failure.


Thanks for providing me these screenshots. I didn’t specify your Android SDK settings from within the editor and that’s my fault - my apologies. Looking at your folders though, I can tell that you’ve installed AndroidWorks, so as long as it’s set up within the engine correctly - you shouldn’t have any problems.

Here is an example of how mine looks:


Thanks! :smiley:

Hi ,

I didn’t notice that settings, but after I set up those folders, I still got the same error. However, I noticed on another page of settings, Platfroms - Android, there is a warning saying “Project is not configured for the Android Platform.” But when I pushed the “Configure Now” button, an error message just popped up, “Could not overwrite project properties file”. Does it have something to do with my build failure?

Does the same error “Could not overwrite Project Properties file.” occur in a new template created, or does it only occur in your project? Have you tried deleting your Intermediate, Saved and Config files from your project folder? If so, were you able to press the “Configure Now” button? That does need to be selected in order to successfully package onto Android.

Looking forward to hearing back, thanks! :slight_smile:

I tired what you said but still got the same error message, “Could not overwrite Project Properties file.” However, I found that the Build folder and its subfolders were all read-only. Even if I tried to remove their attributes of read-only in Windows Explorer, they would be set back to read-only automatically, which was quite weird to me. Does it have something to do with the project properties file? Where should be the project properties file?

By the way, I was just trying to learn how to build Android projects in UE4 and I just followed Android Quick Start and created projects from the ThirdPerson template. I modified nothing except the project settings to build the projects.

Later on I downloaded the installer and installed UE4 instead of compiling one in VS. Then I tried to create an Android project and this time the “Configure Now” button worked without the error “Could not overwrite Project Properties file.” So it looks like there was something wrong with the version I built from the source code. Anyway, thanks for your help again.

Did you resolve your issue? It sounds now that perhaps the Visual Studio version you’re using isn’t the right one. Are you on VS 2015?

Thank you for giving updates!

Yes, I’m using VS2015 and the source code of UE4 I used to compile was the zip from GitHub. I didn’t modify the source code, so I don’t know what’s the difference between the one I built and the one from the installer.

I got this error and resolved it by building UE4 for Android | Development in Visual Studio, and then relaunching the editor.

Hey, I had the same problem building a new project on Mac. I was able to get it to work by simply creating the file in question (it didn’t exist). I did that by running the ‘touch’ command in the Build\Android directory of my project. Hope that helps!

Can you elaborate on this option you set? I can’t find anything about building UE4 specifically for android development in Visual Studio, but I am getting the same error.

@Andy Chang I have hit the same issue. Could you provide more detailed information about that "by building UE4 for Android | Development in Visual Studio "? Really appreciate your help :slight_smile:

@Andy Chang I think I’ve got what you mean. But there is no Android option :- (
Look forward to your reply.


My list has Android as the first option. Do you have [Codeworks][1] installed?

Android Support for Unreal Engine | Unreal Engine 5.2 Documentation

I tried to download and install CodeWorks for many times, but always failed. Luckily, I found someone had uploaded the [folders][1] . So I just copied the **** folder and pointed the Editor to the install locations.
P.S. the version of UE that I use is 4.18.3

UE4 Android打包 - 收藏夹 - 知乎

Hi @Andy Chang ,
I start a new [thread][1] to desribe my problems in detail. Could you give me more help? Thanks :slight_smile:

UE4 Android build error, could not overwrite Project Properties file - Mobile - Epic Developer Community Forums

Finally, I fixed it by run Setup.bat -include=Android instead of Setup.bat. Because the command Setup.bat, by default, only downloads the dependencies for the current platform. ([TUTORIAL] How to use Setup.bat and how to reduce download size][1])

[TUTORIAL] How to use Setup.bat and how to reduce download size - C++ - Epic Developer Community Forums