Android Build Failed

I had posted a similar question a few weeks back, but got no reply, so I’ll try posting again. I’ve been trying to package my game for Android, but no matter what I do, I keep getting the build failed error. I’ve tried looking it up online, but I still cannot build my game. I’ve attached the log file this time.


39388-uat_log.txt (355 KB)

Sadly, the actual error isn’t printing:

UEDeployAndroid.RunCommandLineProgramAndThrowOnError: Preparing native code for debugging...
Running: F://android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a " NDK_DEBUG=1
BuildCommand.Execute: BUILD FAILED
Program.Main: AutomationTool terminated with exception:
Program.Main: Exception in UnrealBuildTool: ERROR: F://android-ndk-r9c/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1

You should go into the /Intermediate/Android/APK directory and run that command (F://android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a " NDK_DEBUG=1) and see if you see any more output.


Hi, thanks for replying. I did that, and here’s what I’m getting

C:\WINDOWS\system32>F://android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a
Android NDK: Could not find application project directory !
Android NDK: Please define the NDK_PROJECT_PATH variable to point to it.
F:\\android-ndk-r9c\build/core/ *** Android NDK: Aborti
ng    .  Stop.

Press any key to continue . . .

You are not running from the proper directory. You need to do this first:

pushd <PathToProject>\Intermediate\Android\APK

something like:

pushd "D:\Unreal Engine\My Projects\AwesomeProject\Intermediate\Android\APK"

Oh ok! I did what you said, and this is the output I got.

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Nitish>pusd C:\Users\Nitish\Documents\Unreal Projects\Blockmania 4.7\In
'pusd' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Nitish>pushd C:\Users\Nitish\Documents\Unreal Projects\Blockmania 4.7\I

C:\Users\Nitish\Documents\Unreal Projects\Blockmania 4.7\Intermediate\Android\AP
K>F://android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a " NDK_DEBUG=1
[armeabi-v7a] Gdbserver      : [arm-linux-androideabi-4.6] libs/armeabi-v7a/gdbs
[armeabi-v7a] Gdbsetup       : libs/armeabi-v7a/gdb.setup
[armeabi-v7a] Prebuilt       : <= jni/armeabi-v7a/
[armeabi-v7a] Install        : => libs/armeabi-v7a/
Press any key to continue . . .

Well frustratingly that looks all good (except for the Press any key to continue at the end - when I run ndk-build, I don’t get that happening). Maybe that is actually not coming from ndk-build?

Basically, I can’t tell what is happening, because command that your log shows is failing is working correctly when you run it…

Oh! Is there anything else I could show you that could give you an idea as to what’s wrong? For starters, I didn’t install UE4 in the default location, neither the android SDK files (The default location is C, but I installed it in F, since I didn’t have space in my C ), but I set it in the project settings. Could that be on any use?

Hello ! I am experiencing the same error while compiling Unreal Engine on Android.

Doing the same command you recommended, I have this error. Could you please help me resolve it ?

D:\UnrealEngine\unrealengine-custom\Engine\Intermediate\Android>C://android-ndk-r11c/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1
Android NDK: Could not find application project directory !
Android NDK: Please define the NDK_PROJECT_PATH variable to point to it.
C:\android-ndk-r11c\build\…\build\core\ *** Android NDK: Aborting . Stop.

Thanks !

Please submit your own AnswerHub thread for additional assistance. This is an older thread and likely the issue is not the same.


hey guys, I had the same problem when I 'am trying to deploy my game on my tablet android 5.1 (API 22) so this is what I did :

  • Project Settings > Android >
  • check Support arm64 [aka arm64-v8a]

just that and then I had the Gradle problem I just unchecked the “Enable Gradle Instead of Ant”

Hope this helps :slight_smile:

Sorry for imposing You . I have landed in this threat because i looking for answers on my problem… every think here : Can't package project on Android AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure) - Platform & Builds - Epic Developer Community Forums

This is 2nd time i posted this threat. PLS help me