Android Build Fail on Making .apk with Ant

Hello :slight_smile:

I’m having big problems to build my game on Android plataform after I upgraded my project/engine to 4.13. update :confused:
I already searched for all possible solutions over the web but nothing worked so far.

My build simply fails on the PERFORMING FINAL APK PACKAGE OPERATION part Making .apk with Ant…

It’s something related with Ant tool, but I have no clue on how to fix it.
Please check the log and hit me with some insights if possible. link text

–What I tried so far:—

-Recompile the game project on VS 2015

-Deleted Intermediate folder

-copy and pasted android-support-v4.jar VrApi.jar vrplatlib.jar to Engine/Build/Android/Java/libs

-hands tight hoping to solve this problem on each build attempt

My specs:

Win 10

UE4 4.13.2

Visual Studio 2015

SDK API Level is setted to matchndk
NDK API Level is setted to android-19

CodeWorks for Android 1R4u2 standard installed

SDK Base 24.4.1

Android Plataform Tools 23.1.0

Android Tools 23.0.3

also installed API 19 and 22

Android Toolchain:
Android NDK 11c
Java SDK 1.7.0_71
Apache Ant 1.8.2

I’m not sure what the cause can be but maybe its not finding libraries or dependences? (I’m not an expert so I’m totally lost by now). I appreciate any help on this problem :slight_smile:

Hy brunogbrito,

Are you sure that you are pointing the right direction in UE4, check this thread, we have a couple of screenshots here:

are your environment variables set right?

Yes, I think so, how do I open that environment panel?

I thought it was something related to my project, but I tried to build a simple third person and had the same issue.

only Source

that’s the thing, there is an important update, sprites and I think also flipbooks can be used inside UMG + a lot of improvements. Audio improvements as well (I hope pitch working fine on mobiles now as well), html5 and others.
I was working in 4.12.5 on another computer.
But can’t build the project in other machines being 4.12 or 4.13, there is always this issue, 2 weeks trying find a solution, can’t find out why,

Seems to be pointed to the right location


Yep, they look ok. To be honest I am kind of out of ideas. Do you have only the Source installed, or you have a binary version too?

By the way, you know that the newest update is not the 4.13 but the 4.14, however if you are in production I wouldnt change versions unless there is a really important update you essentially need for your project.

If you upgraded to the latest, then you upgraded to 4.14. which holds a couple of new features for Android development too, you might want to check out the release features what might cause the issue. If I remember right, there was a possibility to turn the vertex fog off on mobile as well as using Multi View along other changes/new features.

So, my lasts attempts in finding the problem was to build a Third Person Project, it came with the same results. After that I downloaded the engine from the launcher and did the same thing, it worked. So I think the problem is related with my source engine and not the Android SDK. What should I do? rebuild the engine? the project? clean and build a new solution?

Im afraid I cannot help you with the perfect solution, however I ve read somewhere that building the UE4 solution not only as Development_Editor Win64, but also Development Android can solve some issues. Not sure how you are building it usually.

Ok! I finally found the solution

The problem was related with old Project code (Binaries or Build folder)

so I reinstalled Android SDK ( 1R4u2 ) just for sure.
Deleted Project folders: Binaries, Build, Intermediate and DerivedDataCache folder
Generated Project Files, opened VS2015 and build the project again. worked like a charm :slight_smile:

In my special case I had to change my SDK API Level to android-22 due a plugin I’m using.

Hope this help’s someone with similar issue in the future.

im glad it works, and hope that this might be help for some ppl in the future too!