Android build doesn't include certain files

For some reason, for the past while (since like 4.10, I haven’t come back to deal with this issue in awhile) my android build keeps missing files. The output log on the build has no mention of these files at all; they just don’t get included in the build, even though they are used in game.

Eg: one of my level backgrounds (2D game) doesn’t get built at all so the android game has a black background.

I’m at a loss as to what could cause this.


  • Does the background appear when you run the game in Standalone in the editor?
  • Does it only occur when running the game on Android?

It appears fine when running Standalone, or clicking Launch and building on Windows.

If I click launch for my Android device (Galaxy Tab A), it’s missing the background and other assets there. I’ve also had varying results; I remember in the past having all the assets showing up before, even though I had just rebuilt a second time without changing anything. That only happened once though, and every other time I’ve had problems with missing assets.

Does it only occur when you Launch the game? Have you tried packaging the game and deploying the build to your device instead of Launching on the device? It’s possible that the assets are not being cooked when Launching.

Actually yea, it worked when I packaged the game. So it seems to only happen when I Launch.

Go to Edit > Project Settings > Maps & Modes, make sure your Editor, Game, and Server default map are set.


Since the content is working in a packaged game, and not when you Launch, it is most likely that the content is not being cooked. I’d recommend just packaging and deploying the game to your device to ensure that the content is being cooked.

Additionally, you can try adding the asset directories that you want to be cooked to the Additional Asset Directories to Cook under Edit->Project Settings->Packaging, and expanding the dropdown under the Packaging section.

Have a great day