Android Build closes while splash screen without error in output log

I’m trying desperately to build or package on android (Asus Tablet - Android 4.1.1) but the app closes while splash screen. In my opinion there are no errors in the output log:

Hey CornKrue,

In order to better assist you, I’m going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

Hi,

Here are the phone’s logs:

D/dalvikvm(14547): Trying to load lib /data/data/com.TimeLapse.AlienTribes/lib/libgnustl_shared.so 0x412dc2f0
D/dalvikvm(14547): Added shared lib /data/data/com.TimeLapse.AlienTribes/lib/libgnustl_shared.so 0x412dc2f0
D/dalvikvm(14547): No JNI_OnLoad found in /data/data/com.TimeLapse.AlienTribes/lib/libgnustl_shared.so 0x412dc2f0, skipping init
D/dalvikvm(14547): Trying to load lib /data/data/com.TimeLapse.AlienTribes/lib/libvrapi.so 0x412dc2f0
D/dalvikvm(14547): Added shared lib /data/data/com.TimeLapse.AlienTribes/lib/libvrapi.so 0x412dc2f0
D/dalvikvm(14547): No JNI_OnLoad found in /data/data/com.TimeLapse.AlienTribes/lib/libvrapi.so 0x412dc2f0, skipping init
D/dalvikvm(14547): Trying to load lib /data/data/com.TimeLapse.AlienTribes/lib/libUE4.so 0x412dc2f0
W/dalvikvm(14547): Exception Ljava/lang/UnsatisfiedLinkError; thrown while initializing Lcom/epicgames/ue4/GameActivity;
W/dalvikvm(14547): Class init failed in newInstance call (Lcom/epicgames/ue4/GameActivity;)
D/AndroidRuntime(14547): Shutting down VM
W/dalvikvm(14547): threadid=1: thread exiting with uncaught exception (group=0x40cee300)
E/AndroidRuntime(14547): FATAL EXCEPTION: main
E/AndroidRuntime(14547): java.lang.ExceptionInInitializerError
E/AndroidRuntime(14547): 	at java.lang.Class.newInstanceImpl(Native Method)
E/AndroidRuntime(14547): 	at java.lang.Class.newInstance(Class.java:1319)
E/AndroidRuntime(14547): 	at android.app.Instrumentation.newActivity(Instrumentation.java:1053)
E/AndroidRuntime(14547): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1974)
E/AndroidRuntime(14547): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2084)
E/AndroidRuntime(14547): 	at android.app.ActivityThread.access$600(ActivityThread.java:130)
E/AndroidRuntime(14547): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1195)
E/AndroidRuntime(14547): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime(14547): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime(14547): 	at android.app.ActivityThread.main(ActivityThread.java:4745)
E/AndroidRuntime(14547): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(14547): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime(14547): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:786)
E/AndroidRuntime(14547): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
E/AndroidRuntime(14547): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime(14547): Caused by: java.lang.UnsatisfiedLinkError: Cannot load library: link_image[1891]:   117 could not load needed library 'libc++_shared.so' for 'libUE4.so' (load_library[1093]: Library 'libc++_shared.so' not found)
E/AndroidRuntime(14547): 	at java.lang.Runtime.loadLibrary(Runtime.java:370)
E/AndroidRuntime(14547): 	at java.lang.System.loadLibrary(System.java:535)
E/AndroidRuntime(14547): 	at com.epicgames.ue4.GameActivity.<clinit>(GameActivity.java:1768)
E/AndroidRuntime(14547): 	... 15 more
W/ActivityManager(  404):   Force finishing activity com.TimeLapse.AlienTribes/com.epicgames.ue4.GameActivity
W/ActivityManager(  404): Activity pause timeout for ActivityRecord{414d5300 com.TimeLapse.AlienTribes/com.epicgames.ue4.GameActivity}

Thanks for providing me with these logs. The logs are quite short, I do see where the library isn’t being found: " E/AndroidRuntime(14547): Caused by: java.lang.UnsatisfiedLinkError: Cannot load library: link_image[1891]: 117 could not load needed library ‘libc++_shared.so’ for ‘libUE4.so’ (load_library[1093]: Library ‘libc++_shared.so’ not found)"

  • Have you tried rebuilding your project?
  • What about deleting your Intermediate, Saved and Config files from your project folder?
  • Show me a screenshot of your Android SDK within the engine.
  • What is the exact model of your device?

Thanks!

Hey CornKrue,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!