Android ATSC Build keeps failing

Hey all,

I’m trying to get started with Android AR development, but the information I’ve come across isn’t self explanatory, and there is conflicting information on how to set up the development environment correctly, which I think is the issue. What I’ve done so far:

  1. Installed latest version of Android Studio
  2. Up to date with Unreal Engine 4.20.1
  3. Installed the required Visual Studio 2015 Update 3
  4. Ensured C++ Redistributable is installed
  5. Also installed Visual Studio Modelling SDK
  6. Installed CodeWorks-1R7-windows_b104
  7. Restarted PC for good measure

From here I’ve gone into the Project Properties and configured the environment and accepted the SDK. Here is where it gets confusing; there are different sources for where to set up the SDK, NDK, JDK etc directories in Project Settings > Platforms > Android SDK. Some sites say set the location in Username>AppData> etc, other say C:/Android Studio/android-sdk-windows/, but for either directory there is no clear instruction on which sub folders to select, and regardless of all of the option I have tried, nothing seems to work.

I’ve attached the log and a copy of the crash screen, I’ve tried to trace the issue but my knowledge isn’t enough to identify where I’m going wrong. Any help or guidance will be welcome, thanks.

Managed to get this working (eventually). Had to install the SDK’s from within Unreal and not Android Studio. After re-directing these links in project settings, everything worked fine.