Android app going blackscreen after UE logo

Hey, I made unofficial android app for my project that I am not planning to put on Google Play Store.

Packaged it succesfully, app is installing correctly from .apk file.

The problem is:

Even though the app works correctly when using Launch option from the Unreal Engine itself, while installing it manually from .apk packaged file after the app launches and shows the Unreal Engine logo, screen goes completely black.

While installing the app from .apk file I am allowing phone to install it and refuse to send it for scanning as Play Protect marks it as “potentialy dangerous” from not having me on their devs list.

Also, it seems that if phone has leftover files from Launching directly from Unreal Engine 4 (UE4Game folder) even after uninstalling that version from device, newly installed version from .apk file works correctly. With this folder deleted before installing, it shows blackscreen after showing Unreal Engine logo after opening app.

Expected result: (Launching from Unreal Engine or Installing .apk file while having leftover UE4Game folder)

Final result: (Installing from .apk file on fresh device)

Anyone can help me with this case?
1 Like

Nevermind, seems like when I tried to find advanced solutions for this I missed the most obvious thing:

I forgot to check if correct level is set as default in Maps & Modes. Obviously it wasn’t.

Case solved.

thanks bro!!
I’m also finding advanced solution for this, but idk about default maps