Download

Android App crashes on device, cant get passed Unreal Splash Screen

Im doing a development build in 4.25, i can build the app successfully. I can test it in the editor with no problems. But if i try to launch or package and install it on my android device, the app opens, shows the ue4 logo for 2 or 3 seconds, then immediately closes itself. Whats even weirder is i just tried creating a new project, packaging for android, and everything worked fine on my device. I then migrated everything from my old project over (keep in mind, this is a fairly small project, with minimal assets and code), and now I am having the same issue. I cant for the life of me figure out what could be causing this, has this happened to anybody else recently? how did you fix it?

Id just like to add, i have narrowed down the issue to when i change the player controller in the Map and Modes settings, it breaks. if i use the default player controller, i can launch the project. I dont understand why that would be causing the app to crash

Does it crash on armv7 only? I’m having the same problem. A 4 month work project it’s gone now. Even with 4.26 preview can’t solve it.
Even on fresh projects I get crashes, but when I’m using vector arrays only or array structs.

i cant remember exactly how i fixed it, but it was a really stupid setting in the project settings that was blank. It was something like the project name or project description was blank or didnt match the name of the project in unreal, or it might of been that the version number had a decimal and it had to be an integer? honestly just go through the project settings pages and look for useless settings like that that you’re probably not even using, one of them will fix it.

@butavpaul
did you solve this problem , I need help.

Hey, I’m facing the same problem. It only seems to crash on armv7 builds. 64 bit builds work fine. Did you manage to find a solution ? I’m also on 4.25

HHello man. I may did suffer them problem like u :)))
U may can try this:

  1. In Project plugin/ Turn off plugin name (editor scripting utility_ some how this turn on in my project when I migrate to new project)
  2. Check your api version and Android version of your Testing device. U should set Api minimum version to 26 and maximum version to 29 to work well with Android 8-10
  3. If that doesn’t work. U may have to check for Log file in your Mobile to find out what cause the crash on your device. Usually that located in UE4/ Config /Logs.text (or u can search for that) then send me your Log so we can look for right direction.