Android App crashes at launch (open gl error)


I recently moved my android app project on 4.16 version of Unreal.

Packaging is working fine but after I install the app on my Asus Zenfone 2, I can see the slapsh screen until it crashes.

I’ve tried to package as shipping and development, I correctly generated a keystore file, I’ve tried ETC 1 and Android (all) packaging. It doesn’t work.

When I launch Android device monitor, it tells me " E/libEGL(3635): called unimplemented OpenGL ES API "

I don’t know what to do ? Can someone help me ?
Thank you.

I’m having problems with my zenfone 2 too. Did you built unreal from source? What platform are you targeting (ARM or X86)? Does it work in the android X86 emulator? If it is X86 platform my game and tests shows its not working, they even crash in the android x86 emulator. If its ARM my game crashes after i do some 5 to 6 load new level calls on the Zenfone 2 (libhoudini crashes - Libhoudini is the ARM emulator).

Can you post your tombstone file and the monitor log? The tombstone file is in the /data/tombstones folder (i had to root my zenfone 2 to access this folder).

Has anyone successfully build an apk that uses the android x86 ABI with Unreal 4.16?