Android .apk installed, content required for game is missing

Hi, I packed my app to .apk for Android and it installed successfully on the device but everytime i start this app there appears a black screen. This screen is there until I close the App. What can I do to make the app working?

It sounds like the content required for your game is missing, I’ve not tried creating a standalone apk yet but I know when you deploy to your phone via the edito it creates additional folders. Make sure it’s creating a “GAME_TITLE” folder on the root of your SDCARD, where “GAME_TITLE” is the name of your project. This will contain all the content of your game.

and if there isn’t this folder what can I do than?

I haven’t looked into this side of UE4 yet but to create a standalone apk package I believe you have to use UE4Frontend.exe which is located at “\Unreal Engine\4.0\Engine\Binaries\Win64” (if running Windows 64-bit) and launch that, it will have a bunch of settings and configurations to deploy to different platforms. Give that a go.

What steps did you take to package and install your app?

You can make an APK package by using the File > Package Project workflow in the editor without using UnrealFrontend. UFE still needs some polish, so it’s largely “use at your own risk” right now.

Ah cool thanks for the info

Hi Bostrot,

We have not heard from you in quite some time. I am accepting the answer by cdrose for tracking purposes, if you are still having this issue please feel free to continue the conversation. Thank you!

Getting the same error, any fixes?


Unfortunately this question is highly outdated as the engine has gone through significant changes. If you are experiencing a .apk error it would be best to open a new question so we can assist you on your specific bug. In it, please include what device you are using as well as what steps you took to package and install your app.

Thanks for the response! Here it is: